summaryrefslogtreecommitdiffstats
path: root/package/luafilesystem/luafilesystem.mk
diff options
context:
space:
mode:
authorFrancois Perrad2010-08-05 16:36:34 +0200
committerThomas Petazzoni2010-08-24 15:05:19 +0200
commite6c4ce6cef9f260226081f043b4f03dd4b0ad949 (patch)
tree02c53b1269b06a6680f4660baff5a58b7258fd1d /package/luafilesystem/luafilesystem.mk
parentAdd new upstream Lua patches and rename all patches for consistency (diff)
downloadbuildroot-e6c4ce6cef9f260226081f043b4f03dd4b0ad949.tar.gz
buildroot-e6c4ce6cef9f260226081f043b4f03dd4b0ad949.tar.xz
buildroot-e6c4ce6cef9f260226081f043b4f03dd4b0ad949.zip
luafilesystem: remove LARGE_FILE constraint
Add a patch to luafilesystem so that it builds correctly when large files are not supported. This allows to remove the dependency of luafilesystem on large file support on the toolchain. Packages such as cgilua, wsapi and xavante, which depend on luafilesystem, also get their dependency on large file support removed. Fixes bug #2359. Signed-off-by: Francois Perrad <francois.perrad@gadz.org> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Diffstat (limited to 'package/luafilesystem/luafilesystem.mk')
-rw-r--r--package/luafilesystem/luafilesystem.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/luafilesystem/luafilesystem.mk b/package/luafilesystem/luafilesystem.mk
index a27080cd6..e68873414 100644
--- a/package/luafilesystem/luafilesystem.mk
+++ b/package/luafilesystem/luafilesystem.mk
@@ -8,8 +8,12 @@ LUAFILESYSTEM_VERSION = 1.5.0
LUAFILESYSTEM_SITE = http://github.com/downloads/keplerproject/luafilesystem
LUAFILESYSTEM_DEPENDENCIES = lua
+ifeq ($(BR2_LARGEFILE),y)
+LFS_CFLAGS = -D_FILE_OFFSET_BITS=64 _LARGEFILE64_SOURCE
+endif
+
define LUAFILESYSTEM_BUILD_CMDS
- $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -fPIC"
+ $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) $(LFS_CFLAGS) -fPIC"
endef
define LUAFILESYSTEM_INSTALL_TARGET_CMDS