summaryrefslogtreecommitdiffstats
path: root/package/lvm2
diff options
context:
space:
mode:
authorEric Andersen2005-06-24 04:46:31 +0200
committerEric Andersen2005-06-24 04:46:31 +0200
commita8a6587d1b6bd17e8aceff319f2ae6a177dd29d3 (patch)
tree8f05607ca3fb79508763a49cdbf28adc86aac7a7 /package/lvm2
parentIf you update the kernel headers tarball and run make against an already built (diff)
downloadbuildroot-a8a6587d1b6bd17e8aceff319f2ae6a177dd29d3.tar.gz
buildroot-a8a6587d1b6bd17e8aceff319f2ae6a177dd29d3.tar.xz
buildroot-a8a6587d1b6bd17e8aceff319f2ae6a177dd29d3.zip
This patch adds package configuration files for the LVM2 tools and its
dependency, device-mapper. This will provide the basic tools needed to work with LVM2 volumes on the target system. http://bugs.busybox.net/view.php?id=183
Diffstat (limited to 'package/lvm2')
-rw-r--r--package/lvm2/Config.in8
-rw-r--r--package/lvm2/lvm2.mk78
2 files changed, 86 insertions, 0 deletions
diff --git a/package/lvm2/Config.in b/package/lvm2/Config.in
new file mode 100644
index 000000000..0e1e0b32a
--- /dev/null
+++ b/package/lvm2/Config.in
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LVM2
+ bool "lvm2"
+ default n
+ select BR2_PACKAGE_DM
+ help
+ LVM2 refers to a new userspace toolset that provide logical
+ volume management facilities on linux. It is reasonably backwards-
+ compatible with the original LVM toolset.
diff --git a/package/lvm2/lvm2.mk b/package/lvm2/lvm2.mk
new file mode 100644
index 000000000..aa4597491
--- /dev/null
+++ b/package/lvm2/lvm2.mk
@@ -0,0 +1,78 @@
+#############################################################
+#
+# lvm2
+#
+#############################################################
+# Copyright (C) 2005 by Richard Downer <rdowner@gmail.com>
+# Derived from work
+# Copyright (C) 2001-2005 by Erik Andersen <andersen@codepoet.org>
+# Copyright (C) 2002 by Tim Riker <Tim@Rikers.org>
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Library General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Library General Public License for more details.
+#
+# You should have received a copy of the GNU Library General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA
+
+LVM2_BASEVER=2.00
+LVM2_PATCH=33
+LVM2_VERSION=$(LVM2_BASEVER).$(LVM2_PATCH)
+LVM2_SOURCE:=LVM2.$(LVM2_VERSION).tgz
+LVM2_SITE:=ftp://sources.redhat.com/pub/lvm2
+LVM2_CAT:=zcat
+LVM2_DIR:=$(BUILD_DIR)/LVM2.$(LVM2_VERSION)
+LVM2_SBIN:=lvchange lvcreate lvdisplay lvextend lvm lvmchange lvmdiskscan lvmsadc lvmsar lvreduce lvremove lvrename lvresize lvs lvscan pvchange pvcreate pvdisplay pvmove pvremove pvresize pvs pvscan vgcfgbackup vgcfgrestore vgchange vgck vgconvert vgcreate vgdisplay vgexport vgextend vgimport vgmerge vgmknodes vgreduce vgremove vgrename vgs vgscan vgsplit
+LVM2_TARGET_SBINS=$(foreach lvm2sbin, $(LVM2_SBIN), $(TARGET_DIR)/sbin/$(lvm2sbin))
+
+$(DL_DIR)/$(LVM2_SOURCE):
+ $(WGET) -P $(DL_DIR) $(LVM2_SITE)/$(LVM2_SOURCE)
+
+$(LVM2_DIR)/.unpacked: $(DL_DIR)/$(LVM2_SOURCE)
+ $(LVM2_CAT) $(DL_DIR)/$(LVM2_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+ touch $(LVM2_DIR)/.unpacked
+
+$(LVM2_DIR)/.configured: $(LVM2_DIR)/.unpacked
+ (cd $(LVM2_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ $(DISABLE_NLS) \
+ $(DISABLE_LARGEFILE) \
+ --with-user=$(shell id -un) --with-group=$(shell id -gn) \
+ );
+ touch $(LVM2_DIR)/.configured
+
+$(LVM2_TARGET_SBINS): $(LVM2_DIR)/.configured
+ $(MAKE) CC=$(TARGET_CC) -C $(LVM2_DIR)
+ $(MAKE) CC=$(TARGET_CC) -C $(LVM2_DIR) install prefix=$(STAGING_DIR) exec_prefix=$(STAGING_DIR)
+ for binary in $(LVM2_SBIN); do echo $$binary; cp -a $(STAGING_DIR)/sbin/$$binary $(TARGET_DIR)/sbin; done
+
+lvm2: uclibc dm $(LVM2_TARGET_SBINS)
+
+lvm2-clean:
+ $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(LVM2_DIR) uninstall
+ -$(MAKE) -C $(LVM2_DIR) clean
+
+lvm2-dirclean:
+ rm -rf $(LVM2_DIR)
+
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_LVM2)),y)
+TARGETS+=lvm2
+endif