summaryrefslogtreecommitdiffstats
path: root/package/microperl/microperl-uudmap.patch
diff options
context:
space:
mode:
authorGustavo Zacarias2012-03-07 17:52:42 +0100
committerPeter Korsgaard2012-03-08 22:50:31 +0100
commit335260afd429d694cddd7ada705184ad6717826a (patch)
treec539e52bfa5f15c773515fdd1d5dbeee28336003 /package/microperl/microperl-uudmap.patch
parentkmod: bump version (diff)
downloadbuildroot-335260afd429d694cddd7ada705184ad6717826a.tar.gz
buildroot-335260afd429d694cddd7ada705184ad6717826a.tar.xz
buildroot-335260afd429d694cddd7ada705184ad6717826a.zip
microperl: bump to version 5.12.4 and convert to gentargets
* Convert microperl to gentargets infrastructure * Bump to a more modern version 5.12.4 * Introduce the bundle options to simplify people's lives host-microperl is a fully-fledged perl. For the time being we can't build XS modules thus breaking target automake support for example since it requires IO. target-automake was broken before anyway since the automake version bump. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/microperl/microperl-uudmap.patch')
-rw-r--r--package/microperl/microperl-uudmap.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/microperl/microperl-uudmap.patch b/package/microperl/microperl-uudmap.patch
new file mode 100644
index 000000000..c72f9c9a1
--- /dev/null
+++ b/package/microperl/microperl-uudmap.patch
@@ -0,0 +1,47 @@
+From a82b5f080d91ffe184d8ac4795ac71e72e612c2f Mon Sep 17 00:00:00 2001
+From: David Leadbeater <dgl@dgl.cx>
+Date: Mon, 7 Mar 2011 18:40:55 +0000
+Subject: [PATCH] microperl: Update generate_uudmap in Makefile.micro
+
+Makefile.micro hadn't kept up with the changes for generate_uudmap,
+make it match the real Makefile.
+---
+ Makefile.micro | 8 ++++----
+ 1 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile.micro b/Makefile.micro
+index 4b738f5..567d98a 100644
+--- a/Makefile.micro
++++ b/Makefile.micro
+@@ -35,7 +35,7 @@ H = av.h uconfig.h cop.h cv.h embed.h embedvar.h form.h gv.h handy.h \
+ HE = $(H) EXTERN.h
+
+ clean:
+- -rm -f $(O) microperl generate_uudmap$(_X) uudmap.h
++ -rm -f $(O) microperl generate_uudmap$(_X) uudmap.h bitcount.h
+
+ distclean: clean
+
+@@ -74,7 +74,7 @@ udoop$(_O): $(HE) doop.c
+ udump$(_O): $(HE) dump.c regcomp.h regnodes.h
+ $(CC) $(CCFLAGS) -o $@ $(CFLAGS) dump.c
+
+-uglobals$(_O): $(H) globals.c INTERN.h perlapi.h
++uglobals$(_O): $(H) globals.c INTERN.h perlapi.h uudmap.h bitcount.h
+ $(CC) $(CCFLAGS) -o $@ $(CFLAGS) globals.c
+
+ ugv$(_O): $(HE) gv.c
+@@ -173,8 +173,8 @@ uutil$(_O): $(HE) util.c
+ uperlapi$(_O): $(HE) perlapi.c perlapi.h
+ $(CC) $(CCFLAGS) -o $@ $(CFLAGS) perlapi.c
+
+-uudmap.h: generate_uudmap$(_X)
+- $(RUN) ./generate_uudmap$(_X) >uudmap.h
++uudmap.h bitcount.h: generate_uudmap$(_X)
++ $(RUN) ./generate_uudmap$(_X) uudmap.h bitcount.h
+
+ generate_uudmap$(_O): generate_uudmap.c
+ $(CC) $(CCFLAGS) -o $@ $(CFLAGS) generate_uudmap.c
+--
+1.6.5.2.74.g610f9.dirty
+