summaryrefslogtreecommitdiffstats
path: root/package/midori/midori.mk
diff options
context:
space:
mode:
authorJohn Voltz2008-03-06 19:18:35 +0100
committerJohn Voltz2008-03-06 19:18:35 +0100
commit1e19e92f0081e27c7a413d9cd94db65e4ddb0f00 (patch)
tree9ce3f64e36bac3dcb5b30593990b783152af9355 /package/midori/midori.mk
parentfixed metacity makefile (diff)
downloadbuildroot-1e19e92f0081e27c7a413d9cd94db65e4ddb0f00.tar.gz
buildroot-1e19e92f0081e27c7a413d9cd94db65e4ddb0f00.tar.xz
buildroot-1e19e92f0081e27c7a413d9cd94db65e4ddb0f00.zip
added midori browser
Diffstat (limited to 'package/midori/midori.mk')
-rw-r--r--package/midori/midori.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/midori/midori.mk b/package/midori/midori.mk
new file mode 100644
index 000000000..6e81effa6
--- /dev/null
+++ b/package/midori/midori.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# midori
+#
+#############################################################
+
+MIDORI_VERSION = 0.0.17
+MIDORI_SOURCE = midori-$(MIDORI_VERSION).tar.gz
+MIDORI_SITE = http://software.twotoasts.de/media/midori/
+MIDORI_AUTORECONF = YES
+MIDORI_INSTALL_STAGING = NO
+MIDORI_INSTALL_TARGET = YES
+
+MIDORI_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) --prefix=/usr --sysconfdir=/etc \
+ PKG_CONFIG_PATH=$(STAGING_DIR)/usr/lib/pkgconfig
+
+
+MIDORI_DEPENDENCIES = uclibc webkit libsexy $(XSERVER)
+
+$(eval $(call AUTOTARGETS,package,midori))