summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mpd
diff options
context:
space:
mode:
authorGustavo Zacarias2011-02-09 14:25:53 +0100
committerPeter Korsgaard2011-02-09 22:50:25 +0100
commit0b482314f87281db1f9fba028b028e1542ccf463 (patch)
tree73c08cee8998ae87d473360c29e5d0021bbd8b8c /package/multimedia/mpd
parentmpd: fix libao support (diff)
downloadbuildroot-0b482314f87281db1f9fba028b028e1542ccf463.tar.gz
buildroot-0b482314f87281db1f9fba028b028e1542ccf463.tar.xz
buildroot-0b482314f87281db1f9fba028b028e1542ccf463.zip
mpd: fix mpd.conf installation check
If target /etc/mpd.conf exists the evaluation will be fail thus breaking the build process. Fix it. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/mpd')
-rw-r--r--package/multimedia/mpd/mpd.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/multimedia/mpd/mpd.mk b/package/multimedia/mpd/mpd.mk
index 971ad6767..61b107b38 100644
--- a/package/multimedia/mpd/mpd.mk
+++ b/package/multimedia/mpd/mpd.mk
@@ -96,9 +96,10 @@ MPD_CONF_OPT += --disable-wavpack
endif
define MPD_INSTALL_EXTRA_FILES
- [ ! -f $(TARGET_DIR)/etc/mpd.conf ] && \
+ @if [ ! -f $(TARGET_DIR)/etc/mpd.conf ]; then \
$(INSTALL) -D package/multimedia/mpd/mpd.conf \
- $(TARGET_DIR)/etc/mpd.conf
+ $(TARGET_DIR)/etc/mpd.conf; \
+ fi
$(INSTALL) -m 0755 -D package/multimedia/mpd/S95mpd \
$(TARGET_DIR)/etc/init.d/S95mpd
endef