summaryrefslogtreecommitdiffstats
path: root/package/multimedia/tremor/tremor.mk
diff options
context:
space:
mode:
authorSven Neumann2009-12-04 00:02:01 +0100
committerPeter Korsgaard2009-12-08 21:48:46 +0100
commit1dc19c44570031e28ad40a46f4184c5860371eac (patch)
tree23ceb307c498d1f11334488e0c70d64b896972ea /package/multimedia/tremor/tremor.mk
parentkernel-headers: bump 2.6.27.x / 2.6.31.x stable versions (diff)
downloadbuildroot-1dc19c44570031e28ad40a46f4184c5860371eac.tar.gz
buildroot-1dc19c44570031e28ad40a46f4184c5860371eac.tar.xz
buildroot-1dc19c44570031e28ad40a46f4184c5860371eac.zip
libvorbis: split tremor into its own package
This commit splits the Tremor fixed-point implementation out of the libvorbis package and creates a new package called 'tremor' for it. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/tremor/tremor.mk')
-rw-r--r--package/multimedia/tremor/tremor.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/package/multimedia/tremor/tremor.mk b/package/multimedia/tremor/tremor.mk
new file mode 100644
index 000000000..b49337542
--- /dev/null
+++ b/package/multimedia/tremor/tremor.mk
@@ -0,0 +1,31 @@
+############################################################
+#
+# Tremor (Integer decoder for Vorbis)
+#
+############################################################
+
+TREMOR_TRUNK:=http://svn.xiph.org/trunk/Tremor/
+TREMOR_VERSION:=16259
+TREMOR_NAME:=Tremor-svn-r$(TREMOR_VERSION)
+TREMOR_DIR:=$(BUILD_DIR)/$(TREMOR_NAME)
+TREMOR_SOURCE:=$(TREMOR_NAME).tar.bz2
+TREMOR_CAT=$(BZCAT)
+TREMOR_AUTORECONF = YES
+TREMOR_INSTALL_STAGING = YES
+TREMOR_INSTALL_TARGET = YES
+
+$(DL_DIR)/$(TREMOR_SOURCE):
+ $(SVN_CO) -r $(TREMOR_VERSION) $(TREMOR_TRUNK) $(TREMOR_DIR)
+ tar -cv -C $(BUILD_DIR) $(TREMOR_NAME) | bzip2 - -c > $@
+
+$(eval $(call AUTOTARGETS,package/multimedia,tremor))
+
+
+############################################################
+#
+# Toplevel Makefile options
+#
+############################################################
+ifeq ($(BR2_PACKAGE_TREMOR),y)
+TARGETS+=tremor
+endif