summaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorPeter Korsgaard2008-07-01 21:24:36 +0200
committerPeter Korsgaard2008-07-01 21:24:36 +0200
commit49b38b5009eef8e59936d0619c3634b07664b28a (patch)
tree416ea8b8dc43449aafae68a195f5e87218cc6be4 /package/ncurses
parentvalgrind: don't remove TARGET_DIR/usr/lib/pkgconfig (diff)
downloadbuildroot-49b38b5009eef8e59936d0619c3634b07664b28a.tar.gz
buildroot-49b38b5009eef8e59936d0619c3634b07664b28a.tar.xz
buildroot-49b38b5009eef8e59936d0619c3634b07664b28a.zip
ncurses: don't follow symlink on ln invocation
The ln -sf command would fail if $TARGET_DIR/usr/lib/terminfo already exists as we don't have write permissions to the symlink target. Fixed by adding -n option (don't dereference link).
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index e3ff6bc7d..7163af4d0 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -113,7 +113,7 @@ endif
ifeq ($(strip $(BR2_PACKAGE_NCURSES_TARGET_MENU)),y)
cp -dpf $(NCURSES_DIR)/lib/libmenu.so* $(TARGET_DIR)/usr/lib/
endif
- ln -sf /usr/share/terminfo $(TARGET_DIR)/usr/lib/terminfo
+ ln -snf /usr/share/terminfo $(TARGET_DIR)/usr/lib/terminfo
mkdir -p $(TARGET_DIR)/usr/share/terminfo/x
cp -dpf $(STAGING_DIR)/usr/share/terminfo/x/xterm $(TARGET_DIR)/usr/share/terminfo/x
cp -dpf $(STAGING_DIR)/usr/share/terminfo/x/xterm-color $(TARGET_DIR)/usr/share/terminfo/x