summaryrefslogtreecommitdiffstats
path: root/package/ncurses
diff options
context:
space:
mode:
authorEric Andersen2007-01-14 04:52:21 +0100
committerEric Andersen2007-01-14 04:52:21 +0100
commit732d94d25fd10fff65a378b03c3fca9bde403e95 (patch)
treeb9a58d5d379614371b65b671fb7851622a6b5667 /package/ncurses
parentfilter pkgconfig output to force it do use our staging_dir and not (diff)
downloadbuildroot-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.gz
buildroot-732d94d25fd10fff65a378b03c3fca9bde403e95.tar.xz
buildroot-732d94d25fd10fff65a378b03c3fca9bde403e95.zip
fixup a whole steaming pile of insanity. When packages are configured,
they should be configured with --prefix=/usr and we then need to use make DESTDIR=$(STAGING_DIR) install to get things installed into the staging directory. The current situation for many packages, which use --prefix=$(STAGING_DIR) results in the staging_dir paths getting compiled into the binary itself. This also adds in a pile of libtool fixups. Between broken pkgconfig, broken libtool handling, and broken --prefix settings, its a wonder things have worked as well as they have up till now. -Erik
Diffstat (limited to 'package/ncurses')
-rw-r--r--package/ncurses/ncurses.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/ncurses/ncurses.mk b/package/ncurses/ncurses.mk
index ac9f8ad48..11cc87c7b 100644
--- a/package/ncurses/ncurses.mk
+++ b/package/ncurses/ncurses.mk
@@ -48,20 +48,22 @@ $(NCURSES_DIR)/.configured: $(NCURSES_DIR)/.dist
CFLAGS="$(TARGET_CFLAGS)" \
./configure \
--target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
+ --host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--sbindir=/usr/sbin \
+ --libdir=/lib \
+ --libexecdir=/lib \
--sysconfdir=/etc \
--datadir=/usr/share \
--localstatedir=/var \
+ --includedir=/include \
--mandir=/usr/man \
--infodir=/usr/info \
--with-terminfo-dirs=/usr/share/terminfo \
--with-default-terminfo-dir=/usr/share/terminfo \
- --libdir=$(STAGING_DIR)/lib \
--with-shared --without-cxx --without-cxx-binding \
--without-ada --without-progs $(DISABLE_NLS) \
--without-profile --without-debug --disable-rpath \