summaryrefslogtreecommitdiffstats
path: root/package/openssh/openssh.mk
diff options
context:
space:
mode:
authorEric Andersen2005-02-10 04:06:39 +0100
committerEric Andersen2005-02-10 04:06:39 +0100
commitd06645d8eddce3a22144a9ef8961a8f7599d319e (patch)
tree526cac83ded3499b57032bb118ffbab0b72222d4 /package/openssh/openssh.mk
parentmenuconfig -> config (diff)
downloadbuildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.gz
buildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.tar.xz
buildroot-d06645d8eddce3a22144a9ef8961a8f7599d319e.zip
There is no need to have a separate 'Makefile.in' file in the
general case, therefore, combine the toplevel Makefile options such as setting TARGETS into the per-package *.mk file
Diffstat (limited to 'package/openssh/openssh.mk')
-rw-r--r--package/openssh/openssh.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/openssh/openssh.mk b/package/openssh/openssh.mk
index fc1d001a3..54ad325d7 100644
--- a/package/openssh/openssh.mk
+++ b/package/openssh/openssh.mk
@@ -74,3 +74,11 @@ openssh-clean:
openssh-dirclean:
rm -rf $(OPENSSH_DIR)
+#############################################################
+#
+# Toplevel Makefile options
+#
+#############################################################
+ifeq ($(strip $(BR2_PACKAGE_OPENSSH)),y)
+TARGETS+=openssh
+endif