summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorEric Andersen2004-12-11 14:03:52 +0100
committerEric Andersen2004-12-11 14:03:52 +0100
commit8cdb866d85ac8d810a8d1f090cdafb0c4503248b (patch)
treea16e99c755f2b6961e2184e08edf4e73a6786b83 /package/openssl
parentAdd initial BR2_JLEVEL support, with some exceptions for apps that (diff)
downloadbuildroot-8cdb866d85ac8d810a8d1f090cdafb0c4503248b.tar.gz
buildroot-8cdb866d85ac8d810a8d1f090cdafb0c4503248b.tar.xz
buildroot-8cdb866d85ac8d810a8d1f090cdafb0c4503248b.zip
openssl doesnt like 'make -j'
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/openssl.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 4cac7617f..52ef28ba0 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -32,10 +32,10 @@ $(OPENSSL_DIR)/Makefile: $(OPENSSL_DIR)/.unpacked
shared no-idea no-mdc2 no-rc5)
$(OPENSSL_DIR)/apps/openssl: $(OPENSSL_DIR)/Makefile
- $(MAKE) CC=$(TARGET_CC) -C $(OPENSSL_DIR) all build-shared
+ $(MAKE1) CC=$(TARGET_CC) -C $(OPENSSL_DIR) all build-shared
# Work around openssl build bug to link libssl.so with libcrypto.so.
-rm $(OPENSSL_DIR)/libssl.so.*.*.*
- $(MAKE) CC=$(TARGET_CC) -C $(OPENSSL_DIR) do_linux-shared
+ $(MAKE1) CC=$(TARGET_CC) -C $(OPENSSL_DIR) do_linux-shared
$(STAGING_DIR)/lib/libcrypto.a: $(OPENSSL_DIR)/apps/openssl
$(MAKE) CC=$(TARGET_CC) INSTALL_PREFIX=$(STAGING_DIR) -C $(OPENSSL_DIR) install