summaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
authorEric Andersen2005-07-12 21:53:12 +0200
committerEric Andersen2005-07-12 21:53:12 +0200
commitdadad95190710ae2e7c2c0cc9cacf5541f99c6f7 (patch)
tree93d8e20d5016e75aced3b98dd540b31d050ee9ee /package/openssl
parentPatrick Doyle writes: (diff)
downloadbuildroot-dadad95190710ae2e7c2c0cc9cacf5541f99c6f7.tar.gz
buildroot-dadad95190710ae2e7c2c0cc9cacf5541f99c6f7.tar.xz
buildroot-dadad95190710ae2e7c2c0cc9cacf5541f99c6f7.zip
Thomas Lundquist writes:
If I understand you correctly, you want the ncurses development headers on the target. a patch for this (named target_headers.patch and includes similar options for a few other libs in buildroot) can be found at: http://www.zelow.no/floppyfw/download/Development/Patches/buildroot/ (a few packages there aswell) it will add an option to put headers on target for ncurses, zlib and openssl. Thomas.
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Config.in7
-rw-r--r--package/openssl/openssl.mk5
2 files changed, 11 insertions, 1 deletions
diff --git a/package/openssl/Config.in b/package/openssl/Config.in
index d13768d05..6012fb496 100644
--- a/package/openssl/Config.in
+++ b/package/openssl/Config.in
@@ -8,3 +8,10 @@ config BR2_PACKAGE_OPENSSL
full-strength general-purpose cryptography library.
http://www.openssl.org/
+
+config BR2_PACKAGE_OPENSSL_TARGET_HEADERS
+ bool "openssl headers in target"
+ default n
+ depends on BR2_PACKAGE_OPENSSL
+ help
+ Put openssl headers in the target.
diff --git a/package/openssl/openssl.mk b/package/openssl/openssl.mk
index 4c82060a4..af0266ea9 100644
--- a/package/openssl/openssl.mk
+++ b/package/openssl/openssl.mk
@@ -25,7 +25,7 @@ $(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE)
$(OPENSSL_DIR)/Makefile: $(OPENSSL_DIR)/.unpacked
(cd $(OPENSSL_DIR); \
- CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5" \
+ CFLAGS="-DOPENSSL_NO_KRB5 -DOPENSSL_NO_IDEA -DOPENSSL_NO_MDC2 -DOPENSSL_NO_RC5 $(TARGET_CFLAGS)" \
PATH=$(TARGET_PATH) ./Configure linux-$(ARCH) --prefix=/ \
--openssldir=/usr/lib/ssl -L$(STAGING_DIR)/lib -ldl \
-I$(STAGING_DIR)/include $(OPENSSL_OPTS) no-threads \
@@ -85,3 +85,6 @@ openssl-dirclean:
ifeq ($(strip $(BR2_PACKAGE_OPENSSL)),y)
TARGETS+=openssl
endif
+ifeq ($(strip $(BR2_PACKAGE_OPENSSL_TARGET_HEADERS)),y)
+TARGETS+=openssl-headers
+endif