summaryrefslogtreecommitdiffstats
path: root/package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch
diff options
context:
space:
mode:
authorHans-Christian Egtvedt2008-09-17 10:51:54 +0200
committerHans-Christian Egtvedt2008-09-17 10:51:54 +0200
commit16091faf1e33f7508a1b286e922689904c39b33a (patch)
treead688057de5eb345ac9503e29181ba802216b76c /package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch
parentfindutils: use install-strip for target install (diff)
downloadbuildroot-16091faf1e33f7508a1b286e922689904c39b33a.tar.gz
buildroot-16091faf1e33f7508a1b286e922689904c39b33a.tar.xz
buildroot-16091faf1e33f7508a1b286e922689904c39b33a.zip
oprofile: convert oprofile.mk to use Makefile.autotools.in and bump version
This patch bumps the version to 0.9.4 and converts the oprofile.mk to use Makefile.autotools.in. Patches against 0.9.3 are removed since they are no longer needed and a new patch for 0.9.4 is added. Building for all architectures should now also be possible. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com> Signed-off-by: Fathi Boudra <fboudra@gmail.com>
Diffstat (limited to 'package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch')
-rw-r--r--package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch b/package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch
new file mode 100644
index 000000000..7c4138946
--- /dev/null
+++ b/package/oprofile/oprofile-0.9.4-avr32-enable-lookup_dcookie.patch
@@ -0,0 +1,24 @@
+Index: oprofile-0.9.4/daemon/opd_cookie.c
+===================================================================
+--- oprofile-0.9.4.orig/daemon/opd_cookie.c 2008-07-25 16:00:17.000000000 +0200
++++ oprofile-0.9.4/daemon/opd_cookie.c 2008-07-25 16:00:20.000000000 +0200
+@@ -78,6 +78,19 @@
+ (unsigned long)(cookie & 0xffffffff),
+ (unsigned long)(cookie >> 32), buf, size);
+ }
++#elif (defined(__avr32__))
++static inline int lookup_dcookie(cookie_t cookie, char * buf, size_t size)
++{
++ /* On avr32, the first 64bit arg (cookie) is expected to be in
++ * r11(MSW)/r10(LSW) which normally hold arg 2 and arg 3. The second arg
++ * (buf) is then expected to be in r12 which normally holds the first
++ * arg. Third arg (size) is at the right position.
++ */
++ return syscall(__NR_lookup_dcookie, buf,
++ (unsigned long)(cookie >> 32),
++ (unsigned long)(cookie & 0xffffffff),
++ size);
++}
+ #else
+ static inline int lookup_dcookie(cookie_t cookie, char * buf, size_t size)
+ {