summaryrefslogtreecommitdiffstats
path: root/package/pango/pango.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2008-12-31 10:35:11 +0100
committerPeter Korsgaard2008-12-31 10:35:11 +0100
commite528d99d9667e999438abc3817d8bf417cdfb130 (patch)
tree0105bdc4d59343e795e6feb7d307ae856656cd1a /package/pango/pango.mk
parentlibcurl/libglade: touch _HOOK_POST_INSTALL target (diff)
downloadbuildroot-e528d99d9667e999438abc3817d8bf417cdfb130.tar.gz
buildroot-e528d99d9667e999438abc3817d8bf417cdfb130.tar.xz
buildroot-e528d99d9667e999438abc3817d8bf417cdfb130.zip
pango: add init script to create /etc/pango/pango.modules
It would be nicer to do this at compile time, but then we would need to compile pango for the host as well.
Diffstat (limited to 'package/pango/pango.mk')
-rw-r--r--package/pango/pango.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pango/pango.mk b/package/pango/pango.mk
index d1e4f28b9..9c7862e96 100644
--- a/package/pango/pango.mk
+++ b/package/pango/pango.mk
@@ -55,3 +55,7 @@ PANGO_CONF_OPT = --enable-shared --enable-static \
PANGO_DEPENDENCIES = uclibc gettext libintl pkgconfig libglib2 $(XSERVER) cairo
$(eval $(call AUTOTARGETS,package,pango))
+
+$(PANGO_HOOK_POST_INSTALL):
+ $(INSTALL) -m 755 package/pango/S25pango $(TARGET_DIR)/etc/init.d/
+ touch $@