summaryrefslogtreecommitdiffstats
path: root/package/pciutils/pciutils.mk
diff options
context:
space:
mode:
authorGustavo Zacarias2010-05-06 16:24:36 +0200
committerPeter Korsgaard2010-05-06 23:07:21 +0200
commita5fe7371b28ed52a019dc424821f199d0f86b969 (patch)
treec76ee4e582172cefeebdf6e705eaacb90c004341 /package/pciutils/pciutils.mk
parentusbutils: fix recursive LIBUSB Kconfig issue and bump to 0.87 (diff)
downloadbuildroot-a5fe7371b28ed52a019dc424821f199d0f86b969.tar.gz
buildroot-a5fe7371b28ed52a019dc424821f199d0f86b969.tar.xz
buildroot-a5fe7371b28ed52a019dc424821f199d0f86b969.zip
pciutils: Fix cross compiling
Closes #1705 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/pciutils/pciutils.mk')
-rw-r--r--package/pciutils/pciutils.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/pciutils/pciutils.mk b/package/pciutils/pciutils.mk
index 393162f62..2b999dfb5 100644
--- a/package/pciutils/pciutils.mk
+++ b/package/pciutils/pciutils.mk
@@ -18,10 +18,12 @@ define PCIUTILS_CONFIGURE_CMDS
$(SED) 's/uname -s/echo Linux/' \
-e 's/uname -r/echo $(LINUX_HEADERS_VERSION)/' \
$(PCIUTILS_DIR)/lib/configure
+ $(SED) 's/^STRIP/#STRIP/' $(PCIUTILS_DIR)/Makefile
endef
define PCIUTILS_BUILD_CMDS
$(MAKE) CC="$(TARGET_CC)" \
+ HOST="$(KERNEL_ARCH)-linux" \
OPT="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
RANLIB=$(TARGET_RANLIB) \
@@ -33,8 +35,10 @@ define PCIUTILS_BUILD_CMDS
SHAREDIR=/usr/share/misc
endef
+# Ditch install-lib if SHARED is an option in the future
define PCIUTILS_INSTALL_TARGET_CMDS
$(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install
+ $(MAKE) BUILDDIR=$(@D) -C $(@D) PREFIX=$(TARGET_DIR)/usr install-lib
endef
$(eval $(call GENTARGETS,package,pciutils))