summaryrefslogtreecommitdiffstats
path: root/package/php/php.mk
diff options
context:
space:
mode:
authorGustavo Zacarias2012-06-02 07:32:40 +0200
committerPeter Korsgaard2012-06-05 08:53:19 +0200
commit12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4 (patch)
treef130a418a87c1e4e695c34da0a18f826fc8427f5 /package/php/php.mk
parentbeecrypt: fix build failure of C++ code with g++ 4.7 (diff)
downloadbuildroot-12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4.tar.gz
buildroot-12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4.tar.xz
buildroot-12d80fcf93bbde9e2d929fe04d9a6e7b739d54c4.zip
php: fix WDDX extension build failure
Fix WDDX extension build failure. The documentation and source are conflicting about this, in theory libexpat support is deprecated and libxml2 can replace it, but it seems not so for WDDX, so pull in expat for it. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/php/php.mk')
-rw-r--r--package/php/php.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index e9bda447f..af041c963 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -38,7 +38,6 @@ PHP_CONF_OPT += $(if $(BR2_PACKAGE_PHP_EXT_SOCKETS),--enable-sockets) \
$(if $(BR2_PACKAGE_PHP_EXT_DOM),--enable-dom) \
$(if $(BR2_PACKAGE_PHP_EXT_SIMPLEXML),--enable-simplexml) \
$(if $(BR2_PACKAGE_PHP_EXT_SOAP),--enable-soap) \
- $(if $(BR2_PACKAGE_PHP_EXT_WDDX),--enable-wddx) \
$(if $(BR2_PACKAGE_PHP_EXT_XML),--enable-xml) \
$(if $(BR2_PACKAGE_PHP_EXT_XMLREADER),--enable-xmlreader) \
$(if $(BR2_PACKAGE_PHP_EXT_XMLWRITER),--enable-xmlwriter) \
@@ -68,6 +67,11 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_LIBXML2),y)
PHP_DEPENDENCIES += libxml2
endif
+ifeq ($(BR2_PACKAGE_PHP_EXT_WDDX),y)
+ PHP_CONF_OPT += --enable-wddx --with-libexpat-dir=$(STAGING_DIR)/usr
+ PHP_DEPENDENCIES += expat
+endif
+
ifeq ($(BR2_PACKAGE_PHP_EXT_XMLRPC),y)
PHP_CONF_OPT += --with-xmlrpc \
$(if $(BR2_PACKAGE_LIBICONV),--with-iconv-dir=$(STAGING_DIR)/usr)