summaryrefslogtreecommitdiffstats
path: root/package/php/php.mk
diff options
context:
space:
mode:
authorJohn Voltz2008-03-11 19:14:42 +0100
committerJohn Voltz2008-03-11 19:14:42 +0100
commit554fc8bc7f88cccd3f2f0966b830c9574c64ad63 (patch)
tree238516696247acc341c08cc043306de54d1abfd3 /package/php/php.mk
parentadded debug option (diff)
downloadbuildroot-554fc8bc7f88cccd3f2f0966b830c9574c64ad63.tar.gz
buildroot-554fc8bc7f88cccd3f2f0966b830c9574c64ad63.tar.xz
buildroot-554fc8bc7f88cccd3f2f0966b830c9574c64ad63.zip
fixes for php makefile
Diffstat (limited to 'package/php/php.mk')
-rw-r--r--package/php/php.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/php/php.mk b/package/php/php.mk
index 6d5d0e8e1..195d4669e 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -111,13 +111,14 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_SQLITE_UTF8),y)
endif
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO),y)
- PHP_CONFIGURE+=--with-pdo
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_SQLITE),y)
PHP_CONFIGURE+=--with-pdo-sqlite
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
- PHP_CONFIGURE+=--with-pod-mysql
+ PHP_CONFIGURE+=--with-pdo-mysql
endif
+else
+ PHP_CONFIGURE+=--without-pdo-sqlite
endif
$(DL_DIR)/$(PHP_SOURCE):