summaryrefslogtreecommitdiffstats
path: root/package/php
diff options
context:
space:
mode:
authorPeter Korsgaard2009-02-21 10:06:43 +0100
committerPeter Korsgaard2009-02-21 10:06:43 +0100
commit0524852e7a89d8e10ee39c566ff4383b2030edb1 (patch)
tree2736ee8b818b40208b807ac3b5151e6febf0315f /package/php
parentphp: use alternative download URL so we can use DOWNLOAD macro (diff)
downloadbuildroot-0524852e7a89d8e10ee39c566ff4383b2030edb1.tar.gz
buildroot-0524852e7a89d8e10ee39c566ff4383b2030edb1.tar.xz
buildroot-0524852e7a89d8e10ee39c566ff4383b2030edb1.zip
php: fix sqlite module
- php comes with it's own embedded sqlite, so no need to select sqlite - disable largefile support for !BR2_LARGEFILE - php somehow forgets to link with -ldl, breaking the sqlite extension. Fix it by disabling the (unused?) modload support in sqlite.
Diffstat (limited to 'package/php')
-rw-r--r--package/php/Config.ext1
-rw-r--r--package/php/php.mk7
2 files changed, 5 insertions, 3 deletions
diff --git a/package/php/Config.ext b/package/php/Config.ext
index 7f583fcf8..5c1f3a93f 100644
--- a/package/php/Config.ext
+++ b/package/php/Config.ext
@@ -131,7 +131,6 @@ comment "Database extensions"
config BR2_PACKAGE_PHP_EXT_SQLITE
bool "sqlite"
depends on BR2_PACKAGE_PHP
- select BR2_PACKAGE_SQLITE
default y
help
SQLite
diff --git a/package/php/php.mk b/package/php/php.mk
index 7ccc5985e..3aeb2665f 100644
--- a/package/php/php.mk
+++ b/package/php/php.mk
@@ -109,7 +109,9 @@ endif
### Database extensions
ifeq ($(BR2_PACKAGE_PHP_EXT_SQLITE),y)
PHP_CONFIGURE+=--with-sqlite
- PHP_DEPS+=sqlite
+ifneq ($(BR2_LARGEFILE),y)
+ PHP_CFLAGS+= -DSQLITE_DISABLE_LFS
+endif
ifeq ($(BR2_PACKAGE_PHP_EXT_SQLITE_UTF8),y)
PHP_CONFIGURE+=--enable-sqlite-utf8
endif
@@ -118,6 +120,7 @@ ifeq ($(BR2_PACKAGE_PHP_EXT_PDO),y)
PHP_CONFIGURE+=--enable-pdo
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_SQLITE),y)
PHP_CONFIGURE+=--with-pdo-sqlite
+ PHP_CFLAGS+= -DSQLITE_OMIT_LOAD_EXTENSION
endif
ifeq ($(BR2_PACKAGE_PHP_EXT_PDO_MYSQL),y)
PHP_CONFIGURE+=--with-pdo-mysql=$(STAGING_DIR)/usr
@@ -164,7 +167,7 @@ $(PHP_DIR)/.configured: $(PHP_DIR)/.unpacked
touch $@
$(PHP_DIR)/.built: $(PHP_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(PHP_DIR)
+ $(MAKE) CC="$(TARGET_CC) $(PHP_CFLAGS)" -C $(PHP_DIR)
touch $@
$(PHP_DIR)/.staged: $(PHP_DIR)/.built