summaryrefslogtreecommitdiffstats
path: root/package/python/python-010-disable_modules_and_ssl.patch
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-01-23 18:18:54 +0100
committerBernhard Reutner-Fischer2007-01-23 18:18:54 +0100
commitbef5b36b9e0cfbf2ab80c0de01f465f8e1fc2f06 (patch)
tree1023111d508454c0da8017726c4a39429ebb1428 /package/python/python-010-disable_modules_and_ssl.patch
parent- update timestamp of the build_dir binary by stripping it (diff)
downloadbuildroot-bef5b36b9e0cfbf2ab80c0de01f465f8e1fc2f06.tar.gz
buildroot-bef5b36b9e0cfbf2ab80c0de01f465f8e1fc2f06.tar.xz
buildroot-bef5b36b9e0cfbf2ab80c0de01f465f8e1fc2f06.zip
- fix breakage that got introduced by a malformed context diff. Sorry..
Diffstat (limited to 'package/python/python-010-disable_modules_and_ssl.patch')
-rw-r--r--package/python/python-010-disable_modules_and_ssl.patch6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/python/python-010-disable_modules_and_ssl.patch b/package/python/python-010-disable_modules_and_ssl.patch
index c7d41184e..a690eae38 100644
--- a/package/python/python-010-disable_modules_and_ssl.patch
+++ b/package/python/python-010-disable_modules_and_ssl.patch
@@ -22,9 +22,9 @@ diff -rduNp Python-2.4.2-002/setup.py Python-2.4.2/setup.py
def detect_modules(self):
+ global disable_ssl
- for dir in modules_include_dirs:
- add_dir_to_list(self.compiler.include_dirs, dir)
- for dir in modules_lib_dirs:
+ try:
+ modules_include_dirs = os.environ["PYTHON_MODULES_INCLUDE"].split()
+ except KeyError:
@@ -468,7 +476,8 @@ class PyBuildExt(build_ext):
] )