summaryrefslogtreecommitdiffstats
path: root/package/python/python-2.7-004-no-host-headers-libs.patch
diff options
context:
space:
mode:
authorThomas Petazzoni2011-09-18 18:05:23 +0200
committerPeter Korsgaard2011-09-18 21:05:10 +0200
commit2455c89bab315c0b6842198f16777585029e364f (patch)
tree721daabcba459ded2c463c31a7a118a358c29fc4 /package/python/python-2.7-004-no-host-headers-libs.patch
parentpython: fix build by adding some more patches (diff)
downloadbuildroot-2455c89bab315c0b6842198f16777585029e364f.tar.gz
buildroot-2455c89bab315c0b6842198f16777585029e364f.tar.xz
buildroot-2455c89bab315c0b6842198f16777585029e364f.zip
python: bump to 2.7.2
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/python/python-2.7-004-no-host-headers-libs.patch')
-rw-r--r--package/python/python-2.7-004-no-host-headers-libs.patch22
1 files changed, 12 insertions, 10 deletions
diff --git a/package/python/python-2.7-004-no-host-headers-libs.patch b/package/python/python-2.7-004-no-host-headers-libs.patch
index aed8de6c8..c0c528ace 100644
--- a/package/python/python-2.7-004-no-host-headers-libs.patch
+++ b/package/python/python-2.7-004-no-host-headers-libs.patch
@@ -10,23 +10,25 @@ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
setup.py | 39 +++++++++++++++++++++------------------
1 file changed, 21 insertions(+), 18 deletions(-)
-Index: Python-2.7.1/setup.py
+Index: Python-2.7.2/setup.py
===================================================================
---- Python-2.7.1.orig/setup.py
-+++ Python-2.7.1/setup.py
-@@ -351,8 +351,9 @@
+--- Python-2.7.2.orig/setup.py
++++ Python-2.7.2/setup.py
+@@ -373,9 +373,10 @@
def detect_modules(self):
# Ensure that /usr/local is always used
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
+- self.add_multiarch_paths()
+ if os.environ.get('CROSS_COMPILING') != 'yes':
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+ add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
++ self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.
-@@ -360,10 +361,7 @@
+@@ -383,10 +384,7 @@
# directly since an inconsistently reproducible issue comes up where
# the environment variable is not set even though the value were passed
# into configure and stored in the Makefile (issue found on OS X 10.3).
@@ -38,7 +40,7 @@ Index: Python-2.7.1/setup.py
env_val = sysconfig.get_config_var(env_var)
if env_val:
# To prevent optparse from raising an exception about any
-@@ -388,17 +386,6 @@
+@@ -411,17 +409,6 @@
for directory in reversed(options.dirs):
add_dir_to_list(dir_list, directory)
@@ -56,7 +58,7 @@ Index: Python-2.7.1/setup.py
try:
have_unicode = unicode
except NameError:
-@@ -407,11 +394,16 @@
+@@ -430,11 +417,16 @@
# lib_dirs and inc_dirs are used to search for files;
# if a file is found in one of those directories, it can
# be assumed that no additional -I,-L directives are needed.
@@ -78,7 +80,7 @@ Index: Python-2.7.1/setup.py
exts = []
missing = []
-@@ -844,6 +836,9 @@
+@@ -867,6 +859,9 @@
db_inc_paths.append('/pkg/db-3.%d/include' % x)
db_inc_paths.append('/opt/db-3.%d/include' % x)
@@ -88,7 +90,7 @@ Index: Python-2.7.1/setup.py
# Add some common subdirectories for Sleepycat DB to the list,
# based on the standard include directories. This way DB3/4 gets
# picked up when it is installed in a non-standard prefix and
-@@ -996,6 +991,9 @@
+@@ -1019,6 +1014,9 @@
MIN_SQLITE_VERSION = ".".join([str(x)
for x in MIN_SQLITE_VERSION_NUMBER])
@@ -98,7 +100,7 @@ Index: Python-2.7.1/setup.py
# Scan the default include directories before the SQLite specific
# ones. This allows one to override the copy of sqlite on OSX,
# where /usr/include contains an old version of sqlite.
-@@ -1095,6 +1093,8 @@
+@@ -1118,6 +1116,8 @@
# the more recent berkeleydb's db.h file first in the include path
# when attempting to compile and it will fail.
f = "/usr/include/db.h"