summaryrefslogtreecommitdiffstats
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorDaniel Mack2011-05-31 18:16:34 +0200
committerPeter Korsgaard2011-06-20 11:50:43 +0200
commit377b2785c136e7439ac4f4a6e4509bc5c9fe3015 (patch)
tree0cb01024274a7a156ee196202655796fca843067 /package/qt/qt.mk
parentbmon: add optional alsa support (diff)
downloadbuildroot-377b2785c136e7439ac4f4a6e4509bc5c9fe3015.tar.gz
buildroot-377b2785c136e7439ac4f4a6e4509bc5c9fe3015.tar.xz
buildroot-377b2785c136e7439ac4f4a6e4509bc5c9fe3015.zip
Qt: add config option to build libQtDeclarative module
Signed-off-by: Daniel Mack <zonque@gmail.com> Acked-by: Daniel Nyström <daniel.nystrom@timeterminal.se> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 8bcbd3fef..e8b7a4964 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -398,6 +398,12 @@ else
QT_CONFIGURE_OPTS += -no-stl
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_CONFIGURE_OPTS += -declarative
+else
+QT_CONFIGURE_OPTS += -no-declarative
+endif
+
# ccache and precompiled headers don't play well together
ifeq ($(BR2_CCACHE),y)
QT_CONFIGURE_OPTS += -no-pch
@@ -535,6 +541,9 @@ endif
ifeq ($(BR2_PACKAGE_QT_SCRIPTTOOLS),y)
QT_INSTALL_LIBS += QtScriptTools
endif
+ifeq ($(BR2_PACKAGE_QT_DECLARATIVE),y)
+QT_INSTALL_LIBS += QtDeclarative
+endif
ifeq ($(BR2_PACKAGE_QT_QT3SUPPORT),y)
QT_INSTALL_LIBS += Qt3Support
endif