summaryrefslogtreecommitdiffstats
path: root/package/qt/qt.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2009-12-14 16:54:46 +0100
committerPeter Korsgaard2009-12-14 16:54:46 +0100
commit4e272254c7b53d656af1700a6795ae5299797d0e (patch)
treef03248b44c4aac7b2b294e42bcc6c757efec817d /package/qt/qt.mk
parentqt: tweak gui kconfig (diff)
downloadbuildroot-4e272254c7b53d656af1700a6795ae5299797d0e.tar.gz
buildroot-4e272254c7b53d656af1700a6795ae5299797d0e.tar.xz
buildroot-4e272254c7b53d656af1700a6795ae5299797d0e.zip
package/qt: add font selection
Commit f98547622 (make sure to install all Qt-fonts and true-type-fonts) changed Qt to install all .qpf fonts to the target instead of only a hardcoded subset. Some of those fonts are unfortunately quite big (1-2MB) and are not always needed (japanese, unicode). Instead add a font selection in Kconfig similar to how it is done for pixel depths, and default to the subset we were previously using. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt/qt.mk')
-rw-r--r--package/qt/qt.mk12
1 files changed, 11 insertions, 1 deletions
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 3d58f1fac..d69930b4b 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -220,6 +220,14 @@ endif
endif
+QT_FONTS = $(addprefix $(STAGING_DIR)/usr/lib/fonts/, $(addsuffix *.qpf, \
+ $(if $(BR2_PACKAGE_QT_FONT_MICRO),micro) \
+ $(if $(BR2_PACKAGE_QT_FONT_FIXED),fixed) \
+ $(if $(BR2_PACKAGE_QT_FONT_HELVETICA),helvetica) \
+ $(if $(BR2_PACKAGE_QT_FONT_JAPANESE),japanese) \
+ $(if $(BR2_PACKAGE_QT_FONT_UNIFONT),unifont)))
+
+
ifeq ($(BR2_PACKAGE_QT_QTFREETYPE),y)
QT_CONFIGURE+= -qt-freetype
else
@@ -445,7 +453,9 @@ $(STAGING_DIR)/usr/lib/libQtCore.la: $(QT_TARGET_DIR)/.compiled
qt-gui: $(STAGING_DIR)/usr/lib/libQtCore.la
mkdir -p $(TARGET_DIR)/usr/lib/fonts
- cp -dpf $(STAGING_DIR)/usr/lib/fonts/*.qpf $(TARGET_DIR)/usr/lib/fonts
+ifneq ($(QT_FONTS),)
+ cp -dpf $(QT_FONTS) $(TARGET_DIR)/usr/lib/fonts
+endif
ifneq ($(BR2_PACKAGE_QT_NOFREETYPE),y)
cp -dpf $(STAGING_DIR)/usr/lib/fonts/*.ttf $(TARGET_DIR)/usr/lib/fonts
endif