summaryrefslogtreecommitdiffstats
path: root/package/qt
diff options
context:
space:
mode:
authorDaniel Nyström2011-02-03 00:06:44 +0100
committerPeter Korsgaard2011-02-25 21:45:31 +0100
commitfab79678f017363941d50abe7d12727cc01a3d5b (patch)
tree4779d3409bf812c9de0011ddf868dab44d1dd690 /package/qt
parentsquashfs: use kconfig to ensure atleast one compressor is selected (diff)
downloadbuildroot-fab79678f017363941d50abe7d12727cc01a3d5b.tar.gz
buildroot-fab79678f017363941d50abe7d12727cc01a3d5b.tar.xz
buildroot-fab79678f017363941d50abe7d12727cc01a3d5b.zip
qt: add option to hide mouse cursor
Allow the user to build Qt with the QT_NO_QWS_CURSOR macro set. Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/qt')
-rw-r--r--package/qt/Config.mouse.in7
-rw-r--r--package/qt/qt.mk3
2 files changed, 10 insertions, 0 deletions
diff --git a/package/qt/Config.mouse.in b/package/qt/Config.mouse.in
index 87973d2fe..16c41c18f 100644
--- a/package/qt/Config.mouse.in
+++ b/package/qt/Config.mouse.in
@@ -15,4 +15,11 @@ config BR2_PACKAGE_QT_MOUSE_TSLIB
config BR2_PACKAGE_QT_MOUSE_QVFB
bool "qvfb"
+comment "Mouse Options"
+
+config BR2_PACKAGE_QT_MOUSE_NO_QWS_CURSOR
+ bool "Hide the mouse cursor"
+ help
+ Do not show the mouse cursor in QWS.
+
endmenu
diff --git a/package/qt/qt.mk b/package/qt/qt.mk
index 3dfdcbf0b..cc90190df 100644
--- a/package/qt/qt.mk
+++ b/package/qt/qt.mk
@@ -154,6 +154,9 @@ QT_CONFIGURE += -qt-mouse-qvfb
else
QT_CONFIGURE += -no-mouse-qvfb
endif
+ifeq ($(BR2_PACKAGE_QT_MOUSE_NO_QWS_CURSOR),y)
+QT_CONFIGURE+= -D QT_NO_QWS_CURSOR
+endif
### Keyboard drivers
ifeq ($(BR2_PACKAGE_QT_KEYBOARD_TTY),y)