summaryrefslogtreecommitdiffstats
path: root/package/ramspeed/ramspeed.mk
diff options
context:
space:
mode:
authorGustavo Zacarias2012-05-29 14:33:18 +0200
committerPeter Korsgaard2012-06-13 23:58:33 +0200
commitd9a790945437fe2a62d1871e2641a01077df428f (patch)
treeb2164f958b83220b2050ca4763e4c5c570580351 /package/ramspeed/ramspeed.mk
parentlibroxml: bump version to 2.2.0 (diff)
downloadbuildroot-d9a790945437fe2a62d1871e2641a01077df428f.tar.gz
buildroot-d9a790945437fe2a62d1871e2641a01077df428f.tar.xz
buildroot-d9a790945437fe2a62d1871e2641a01077df428f.zip
ramspeed: new package
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/ramspeed/ramspeed.mk')
-rw-r--r--package/ramspeed/ramspeed.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/ramspeed/ramspeed.mk b/package/ramspeed/ramspeed.mk
new file mode 100644
index 000000000..9ac21ad1e
--- /dev/null
+++ b/package/ramspeed/ramspeed.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# ramspeed
+#
+#############################################################
+
+RAMSPEED_VERSION = 2.6.0
+RAMSPEED_SITE = http://www.alasir.com/software/ramspeed
+RAMSPEED_ARCH = $(if $(BR2_i386),i386)$(if $(BR2_x86_64),x86_64)
+
+define RAMSPEED_BUILD_CMDS
+ cp -f package/ramspeed/Makefile $(@D)
+ CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" \
+ make -C $(@D) $(RAMSPEED_ARCH)
+endef
+
+define RAMSPEED_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 0755 -D $(@D)/ramspeed $(TARGET_DIR)/usr/bin/ramspeed
+endef
+
+$(eval $(call GENTARGETS))