summaryrefslogtreecommitdiffstats
path: root/package/samba/samba.mk
diff options
context:
space:
mode:
author"Steven J. Hill"2007-07-17 02:21:16 +0200
committer"Steven J. Hill"2007-07-17 02:21:16 +0200
commitbc9dcb8574e2a7e536b8176cb5a566cb51a1d7f5 (patch)
treeee755e1c80860881a2f0d874df38518a538ac860 /package/samba/samba.mk
parentA number of fixes including placing of the final image into the 'binaries' di... (diff)
downloadbuildroot-bc9dcb8574e2a7e536b8176cb5a566cb51a1d7f5.tar.gz
buildroot-bc9dcb8574e2a7e536b8176cb5a566cb51a1d7f5.tar.xz
buildroot-bc9dcb8574e2a7e536b8176cb5a566cb51a1d7f5.zip
Bump Samba to latest version and update patches.
Diffstat (limited to 'package/samba/samba.mk')
-rw-r--r--package/samba/samba.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/samba/samba.mk b/package/samba/samba.mk
index e355bf896..8066bc912 100644
--- a/package/samba/samba.mk
+++ b/package/samba/samba.mk
@@ -3,9 +3,9 @@
# samba
#
#############################################################
-SAMBA_VERSION:=3.0.23d
+SAMBA_VERSION:=3.0.25b
SAMBA_SOURCE:=samba-$(SAMBA_VERSION).tar.gz
-SAMBA_SITE:=ftp://us4.samba.org/pub/samba/old-versions/
+SAMBA_SITE:=ftp://us4.samba.org/pub/samba/
SAMBA_DIR:=$(BUILD_DIR)/samba-$(SAMBA_VERSION)/source
SAMBA_CAT:=$(ZCAT)
SAMBA_BINARY:=bin/smbd
@@ -28,6 +28,7 @@ $(SAMBA_DIR)/.configured: $(SAMBA_DIR)/.unpacked
$(TARGET_CONFIGURE_ARGS) \
samba_cv_HAVE_GETTIMEOFDAY_TZ=yes \
samba_cv_USE_SETREUID=yes \
+ samba_cv_HAVE_KERNEL_OPLOCKS_LINUX=yes \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -38,6 +39,7 @@ $(SAMBA_DIR)/.configured: $(SAMBA_DIR)/.unpacked
--with-logfilebase=/var/log/samba \
--with-configdir=/etc/samba \
--without-ldap \
+ --without-libaddns \
--with-included-popt \
--with-included-iniparser \
--disable-cups \
@@ -91,6 +93,10 @@ $(TARGET_DIR)/$(SAMBA_TARGET_BINARY): $(SAMBA_DIR)/$(SAMBA_BINARY)
for file in $(SAMBA_TARGETS_) ; do \
rm -f $(TARGET_DIR)/$$file; \
done
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/$(SAMBA_TARGET_BINARY)
+ for file in $(SAMBA_TARGETS_y) ; do \
+ $(STRIP) --strip-unneeded $(TARGET_DIR)/$$file; \
+ done
$(INSTALL) -m 0755 package/samba/S91smb $(TARGET_DIR)/etc/init.d
@if [ ! -f $(TARGET_DIR)/etc/samba/smb.conf ] ; then \
$(INSTALL) -m 0755 -D package/samba/simple.conf $(TARGET_DIR)/etc/samba/smb.conf; \