summaryrefslogtreecommitdiffstats
path: root/package/sawman
diff options
context:
space:
mode:
authorDaniel Laird2008-10-16 14:10:23 +0200
committerDaniel Laird2008-10-16 14:10:23 +0200
commit7ba44159bdce40745bd8563951d0592cca14e749 (patch)
tree4f91b0ba0589947d1ca0a97f3626e4af31d7a102 /package/sawman
parent- extend documentation to mention adding package/foo/Config.in to package/Con... (diff)
downloadbuildroot-7ba44159bdce40745bd8563951d0592cca14e749.tar.gz
buildroot-7ba44159bdce40745bd8563951d0592cca14e749.tar.xz
buildroot-7ba44159bdce40745bd8563951d0592cca14e749.zip
package/sawman: Add Package SawMan
SaWMan is a new window manager module for use with DirectFB. Its main difference to the default module is that it allows one process to be an application and window manager, implementing all kinds of diversity, while SaWMan is only the working horse. Daniel Laird
Diffstat (limited to 'package/sawman')
-rw-r--r--package/sawman/Config.in12
-rw-r--r--package/sawman/sawman.mk16
2 files changed, 28 insertions, 0 deletions
diff --git a/package/sawman/Config.in b/package/sawman/Config.in
new file mode 100644
index 000000000..8dd3ace2b
--- /dev/null
+++ b/package/sawman/Config.in
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_SAWMAN
+ bool "SawMan (Window Manager)"
+ depends on BR2_PACKAGE_DIRECTFB
+ help
+ SaWMan is a new window manager module for use with DirectFB.
+ Its main difference to the default module is that it allows
+ one process to be an application and window manager,
+ implementing all kinds of diversity, while SaWMan is only the
+ working horse.
+
+ See http://www.directfb.org/downloads/Extras/README.SaWMan
+
diff --git a/package/sawman/sawman.mk b/package/sawman/sawman.mk
new file mode 100644
index 000000000..495687820
--- /dev/null
+++ b/package/sawman/sawman.mk
@@ -0,0 +1,16 @@
+#############################################################
+#
+# SAWMAN
+#
+#############################################################
+SAWMAN_VERSION:=1.2.0-rc1
+SAWMAN_SOURCE:=SaWMan-$(SAWMAN_VERSION).tar.gz
+SAWMAN_SITE:=http://www.directfb.org/downloads/Extras
+SAWMAN_INSTALL_STAGING = YES
+SAWMAN_INSTALL_TARGET = YES
+SAWMAN_CONF_ENV = LDFLAGS="-L$(STAGING_DIR)/usr/lib -Wl,--rpath-link -Wl,$(STAGING_DIR)/usr/lib"
+SAWMAN_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) LDFLAGS=-L$(STAGING_DIR)/usr/lib install-strip
+SAWMAN_DEPENDENCIES = directfb
+
+$(eval $(call AUTOTARGETS,package,sawman))
+