summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Voltz2008-03-07 17:54:45 +0100
committerJohn Voltz2008-03-07 17:54:45 +0100
commit1ec48b2e520808f0ad9b4818437a3fb980a27df5 (patch)
tree5be449e92c91a0398c1563603ba5bc60a7139dbc /package
parentshortened help line lengths (diff)
downloadbuildroot-1ec48b2e520808f0ad9b4818437a3fb980a27df5.tar.gz
buildroot-1ec48b2e520808f0ad9b4818437a3fb980a27df5.tar.xz
buildroot-1ec48b2e520808f0ad9b4818437a3fb980a27df5.zip
remove .a files from lib directories after install
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.autotools.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 7aa8814c3..358e71613 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -231,6 +231,9 @@ $(BUILD_DIR)/%/.stamp_target_installed:
rm -rf $(TARGET_DIR)/$$d $(TARGET_DIR)/usr/$$d; \
done)
find $(TARGET_DIR) -name '*.la' -delete
+ find $(TARGET_DIR)/lib -name '*.a' -delete
+ find $(TARGET_DIR)/usr/lib -name '*.a' -delete
+
touch $@
$(BUILD_DIR)/%/.stamp_cleaned: