summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMike Frysinger2004-10-15 16:40:59 +0200
committerMike Frysinger2004-10-15 16:40:59 +0200
commit72c7cc0c249dff7eb7aa09a25d17e817eb77d6af (patch)
tree34a1573b76ed77857f223287ec196e8987b5db11 /package
parentdo some touching to sync timestamps (diff)
downloadbuildroot-72c7cc0c249dff7eb7aa09a25d17e817eb77d6af.tar.gz
buildroot-72c7cc0c249dff7eb7aa09a25d17e817eb77d6af.tar.xz
buildroot-72c7cc0c249dff7eb7aa09a25d17e817eb77d6af.zip
update to a version of e2fsprogs that builds with sh4, make sure build uses $TARGET_CFLAGS, and compile only the misc subdir since we will be using just mke2fs/badblocks
Diffstat (limited to 'package')
-rw-r--r--package/mke2fs/mke2fs.mk11
1 files changed, 7 insertions, 4 deletions
diff --git a/package/mke2fs/mke2fs.mk b/package/mke2fs/mke2fs.mk
index 10c6768cb..906407a35 100644
--- a/package/mke2fs/mke2fs.mk
+++ b/package/mke2fs/mke2fs.mk
@@ -3,9 +3,10 @@
# mke2fs
#
#############################################################
-MKE2FS_SOURCE=e2fsprogs-1.27.tar.gz
-MKE2FS_SITE=http://aleron.dl.sourceforge.net/sourceforge/e2fsprogs
-MKE2FS_DIR=$(BUILD_DIR)/e2fsprogs-1.27
+MKE2FS_VER:=1.35
+MKE2FS_SOURCE:=e2fsprogs-$(MKE2FS_VER).tar.gz
+MKE2FS_SITE:=http://aleron.dl.sourceforge.net/sourceforge/e2fsprogs
+MKE2FS_DIR:=$(BUILD_DIR)/e2fsprogs-$(MKE2FS_VER)
MKE2FS_CAT:=zcat
MKE2FS_BINARY:=misc/mke2fs
MKE2FS_TARGET_BINARY:=sbin/mke2fs
@@ -22,6 +23,7 @@ $(MKE2FS_DIR)/.unpacked: $(DL_DIR)/$(MKE2FS_SOURCE)
$(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
(cd $(MKE2FS_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
@@ -46,7 +48,8 @@ $(MKE2FS_DIR)/.configured: $(MKE2FS_DIR)/.unpacked
touch $(MKE2FS_DIR)/.configured
$(MKE2FS_DIR)/$(MKE2FS_BINARY): $(MKE2FS_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) -C $(MKE2FS_DIR)
+ $(MAKE) CC=$(TARGET_CC) -C $(MKE2FS_DIR) \
+ PROG_SUBDIRS=misc
$(STRIP) $(MKE2FS_DIR)/misc/mke2fs $(MKE2FS_DIR)/misc/badblocks;
touch -c $(MKE2FS_DIR)/misc/mke2fs