summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-09-20 13:08:13 +0200
committerBernhard Reutner-Fischer2007-09-20 13:08:13 +0200
commitadb399f54a4211c4a3854a4055d43a58d75914e4 (patch)
tree35b6cde910e548a930517275448b281bf6c7ea28 /package
parent- fix source location of libusb libs (diff)
downloadbuildroot-adb399f54a4211c4a3854a4055d43a58d75914e4.tar.gz
buildroot-adb399f54a4211c4a3854a4055d43a58d75914e4.tar.xz
buildroot-adb399f54a4211c4a3854a4055d43a58d75914e4.zip
- this is generic infrastructure, there is no point in special-casing any individual package here.
Don't workaround deficiencies but fix them for real
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.autotools.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/Makefile.autotools.in b/package/Makefile.autotools.in
index 5a89727f6..a2ca927f4 100644
--- a/package/Makefile.autotools.in
+++ b/package/Makefile.autotools.in
@@ -143,6 +143,9 @@ $(BUILD_DIR)/%/.stamp_extracted:
$(Q)touch $@
# Patch
+# XXX: FIXME: This has to be done differently and path-independent, i.e. use
+# XXX: FIXME: the dir-part of the stem as base-dir (instead of hardcoding
+# XXX: FIXME: "package/".
$(BUILD_DIR)/%/.stamp_patched: NAMEVER = $($(PKG)_NAME)-$($(PKG)_VERSION)
$(BUILD_DIR)/%/.stamp_patched:
$(call MESSAGE,"Patching")
@@ -158,7 +161,8 @@ $(BUILD_DIR)/%/.stamp_patched:
fi; \
fi; \
else \
- if test "$(wildcard package/x11r7/$($(PKG)_NAME)/$(NAMEVER)*.patch)" ; then \
+ echo "This must be wrong. Why do you need to special-case _any_ package here? Skipping until this is resolved properly." \
+ if false && test "$(wildcard package/x11r7/$($(PKG)_NAME)/$(NAMEVER)*.patch)" ; then \
toolchain/patch-kernel.sh $(@D) package/x11r7/$($(PKG)_NAME) $(NAMEVER)\*.patch || exit 1 ; \
else \
toolchain/patch-kernel.sh $(@D) package/x11r7/$($(PKG)_NAME) $($(PKG)_NAME)\*.patch || exit 1 ; \