summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-01-30 18:33:53 +0100
committerBernhard Reutner-Fischer2007-01-30 18:33:53 +0100
commitb82245322e04064c097fbdcb1737c084d06b9147 (patch)
treed4db210c0d595c1a26a67fa63a89b4f314d63607 /package
parentbusybox 1.4.0 seems to use CONFIG_PREFIX instead of PREFIX (diff)
downloadbuildroot-b82245322e04064c097fbdcb1737c084d06b9147.tar.gz
buildroot-b82245322e04064c097fbdcb1737c084d06b9147.tar.xz
buildroot-b82245322e04064c097fbdcb1737c084d06b9147.zip
- make absolutely sure that we are not trying to go into jobserver mode for MAKE1
Diffstat (limited to 'package')
-rw-r--r--package/Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/package/Makefile.in b/package/Makefile.in
index aca3e4b07..f8557f700 100644
--- a/package/Makefile.in
+++ b/package/Makefile.in
@@ -1,5 +1,8 @@
-MAKE1=make
-MAKE=make -j$(BR2_JLEVEL)
+ifndef MAKE
+MAKE=make
+endif
+MAKE1:=$(MAKE) MAKE="$(firstword $(MAKE)) -j1"
+MAKE:=$(MAKE) -j$(BR2_JLEVEL)
# Strip off the annoying quoting
ARCH:=$(strip $(subst ",, $(BR2_ARCH)))