summaryrefslogtreecommitdiffstats
path: root/support
diff options
context:
space:
mode:
authorH Hartley Sweeten2011-10-05 01:10:40 +0200
committerPeter Korsgaard2011-10-05 13:57:35 +0200
commit6e3e5a99f7c148ef2fcdb6a033c36e9fe6d7ba94 (patch)
treec9ed0843d89beac79997eccec4e95a50b1a1eac7 /support
parentgst-plugins-bad: fix bzip2 typo (diff)
downloadbuildroot-6e3e5a99f7c148ef2fcdb6a033c36e9fe6d7ba94.tar.gz
buildroot-6e3e5a99f7c148ef2fcdb6a033c36e9fe6d7ba94.tar.xz
buildroot-6e3e5a99f7c148ef2fcdb6a033c36e9fe6d7ba94.zip
pkg-stats: update grep tests for package type
Update the grep tests used to determine the package type. The package name and directory are now worked out magically due to: package: add helper functions to get package name and directory magically Because of this the extra arguments were removed by patches: package: remove useless arguments from GENTARGETS package: remove useless arguments from AUTOTARGETS package: remove useless arguments from CMAKETARGETS Signed-off-by: H Hartley Sweeten <hsweeten@visionengravers.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support')
-rwxr-xr-xsupport/scripts/pkg-stats12
1 files changed, 6 insertions, 6 deletions
diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
index bb1c27d87..8602b0f95 100755
--- a/support/scripts/pkg-stats
+++ b/support/scripts/pkg-stats
@@ -98,27 +98,27 @@ for i in $(find package/ -name '*.mk') ; do
is_manual_target=0
is_manual_host=0
- if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call AUTOTARGETS,host\)" $i > /dev/null ; then
is_auto_host=1
fi
- if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call AUTOTARGETS\)" $i > /dev/null ; then
is_auto_target=1
fi
- if grep -E "\(call GENTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call GENTARGETS,host\)" $i > /dev/null ; then
is_pkg_host=1
fi
- if grep -E "\(call GENTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call GENTARGETS\)" $i > /dev/null ; then
is_pkg_target=1
fi
- if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+ if grep -E "\(call CMAKETARGETS,host\)" $i > /dev/null ; then
is_cmake_host=1
fi
- if grep -E "\(call CMAKETARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+ if grep -E "\(call CMAKETARGETS\)" $i > /dev/null ; then
is_cmake_target=1
fi