summaryrefslogtreecommitdiffstats
path: root/target/u-boot/Makefile.in
diff options
context:
space:
mode:
authorPeter Korsgaard2008-04-23 15:03:53 +0200
committerPeter Korsgaard2008-04-23 15:03:53 +0200
commit5cc50fcb682571acb6e4d05cdff64f281e1be64b (patch)
tree37eed757ccb8fa0eed4496c79289eacc8c8ba58c /target/u-boot/Makefile.in
parentu-boot: use correct ARCH (diff)
downloadbuildroot-5cc50fcb682571acb6e4d05cdff64f281e1be64b.tar.gz
buildroot-5cc50fcb682571acb6e4d05cdff64f281e1be64b.tar.xz
buildroot-5cc50fcb682571acb6e4d05cdff64f281e1be64b.zip
u-boot: tools in target (mkimage, fw_printenv and fw_setenv)
Diffstat (limited to 'target/u-boot/Makefile.in')
-rw-r--r--target/u-boot/Makefile.in25
1 files changed, 23 insertions, 2 deletions
diff --git a/target/u-boot/Makefile.in b/target/u-boot/Makefile.in
index 7b7bf1352..c6abe6ec2 100644
--- a/target/u-boot/Makefile.in
+++ b/target/u-boot/Makefile.in
@@ -20,6 +20,15 @@ else
U_BOOT_INC_CONF_FILE:=$(U_BOOT_DIR)/include/config.h
endif
+U_BOOT_TARGET_TOOLS:=
+ifeq ($(strip $(BR2_TARGET_UBOOT_TOOL_MKIMAGE)),y)
+U_BOOT_TARGET_TOOLS+=$(TARGET_DIR)/usr/bin/mkimage
+endif
+ifeq ($(strip $(BR2_TARGET_UBOOT_TOOL_ENV)),y)
+U_BOOT_TARGET_TOOLS+=$(TARGET_DIR)/usr/sbin/fw_printenv
+endif
+
+
# Define a helper function
define insert_define
@echo "#ifdef $(strip $(1))" >> $(U_BOOT_INC_CONF_FILE)
@@ -113,11 +122,23 @@ $(BINARIES_DIR)/$(U_BOOT_BIN): $(U_BOOT_DIR)/$(U_BOOT_BIN)
cp -dpf $(U_BOOT_DIR)/$(U_BOOT_BIN) $(BINARIES_DIR)
cp -dpf $(U_BOOT_DIR)/tools/$(U_BOOT_TOOLS_BIN) $(STAGING_DIR)/usr/bin/
-u-boot: gcc $(BINARIES_DIR)/$(U_BOOT_BIN)
+$(TARGET_DIR)/usr/bin/mkimage: $(U_BOOT_DIR)/$(U_BOOT_BIN)
+ $(TARGET_CC) -I$(U_BOOT_DIR)/include -DUSE_HOSTCC -o $@ \
+ $(U_BOOT_DIR)/tools/mkimage.c $(U_BOOT_DIR)/tools/crc32.c
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
+
+$(TARGET_DIR)/usr/sbin/fw_printenv: $(U_BOOT_DIR)/$(U_BOOT_BIN)
+ $(TARGET_CC) -I$(U_BOOT_DIR)/include -I$(LINUX_HEADERS_DIR)/include \
+ -DUSE_HOSTCC -o $@ \
+ $(U_BOOT_DIR)/tools/env/*.c $(U_BOOT_DIR)/tools/crc32.c
+ $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $@
+ ln -s fw_printenv $(TARGET_DIR)/usr/sbin/fw_setenv
+
+u-boot: gcc $(BINARIES_DIR)/$(U_BOOT_BIN) $(U_BOOT_TARGET_TOOLS)
u-boot-clean:
-$(MAKE) -C $(U_BOOT_DIR) clean
- rm -f $(STAGING_DIR)/usr/bin/$(U_BOOT_TOOLS_BIN)
+ rm -f $(STAGING_DIR)/usr/bin/$(U_BOOT_TOOLS_BIN) $(U_BOOT_TARGET_TOOLS)
u-boot-dirclean:
rm -rf $(U_BOOT_DIR)