summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorEric Andersen2004-10-09 06:34:21 +0200
committerEric Andersen2004-10-09 06:34:21 +0200
commit4c4768b2f79d984a09acc7695a481e2ca281aeb2 (patch)
tree564d9f1d477d450c1b60677ada3c30f3981ae0c4 /target
parentRemove references to the obsolete SOURCE_DIR (diff)
downloadbuildroot-4c4768b2f79d984a09acc7695a481e2ca281aeb2.tar.gz
buildroot-4c4768b2f79d984a09acc7695a481e2ca281aeb2.tar.xz
buildroot-4c4768b2f79d984a09acc7695a481e2ca281aeb2.zip
Fix it so we once again build the target root_fs
Diffstat (limited to 'target')
-rw-r--r--target/Config.in3
-rw-r--r--target/cramfs/Config.in2
-rw-r--r--target/ext2/Config.in6
-rw-r--r--target/ext2/Makefile.in3
-rw-r--r--target/jffs2/Config.in6
-rw-r--r--target/jffs2/Makefile.in3
6 files changed, 22 insertions, 1 deletions
diff --git a/target/Config.in b/target/Config.in
index dbc631725..cd67a718f 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -3,6 +3,9 @@
menu "Target Options"
source "target/cramfs/Config.in"
+source "target/ext2/Config.in"
+source "target/jffs2/Config.in"
+source "target/squashfs/Config.in"
endmenu
diff --git a/target/cramfs/Config.in b/target/cramfs/Config.in
index 2ba1cdece..c9b1fb9f1 100644
--- a/target/cramfs/Config.in
+++ b/target/cramfs/Config.in
@@ -1,5 +1,5 @@
config BR2_TARGET_ROOTFS_CRAMFS
- bool "Build a cramfs root filesystem for the target device"
+ bool "cramfs root filesystem for the target device"
default n
help
Build a cramfs root filesystem
diff --git a/target/ext2/Config.in b/target/ext2/Config.in
new file mode 100644
index 000000000..7e137ae41
--- /dev/null
+++ b/target/ext2/Config.in
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_EXT2
+ bool "ext2 root filesystem for the target device"
+ default y
+ help
+ Build an ext2 root filesystem
+
diff --git a/target/ext2/Makefile.in b/target/ext2/Makefile.in
new file mode 100644
index 000000000..990407718
--- /dev/null
+++ b/target/ext2/Makefile.in
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_TARGET_ROOTFS_EXT2)),y)
+TARGETS+=ext2root
+endif
diff --git a/target/jffs2/Config.in b/target/jffs2/Config.in
new file mode 100644
index 000000000..0d79dd1ff
--- /dev/null
+++ b/target/jffs2/Config.in
@@ -0,0 +1,6 @@
+config BR2_TARGET_ROOTFS_JFFS2
+ bool "jffs2 root filesystem for the target device"
+ default n
+ help
+ Build a jffs2 root filesystem
+
diff --git a/target/jffs2/Makefile.in b/target/jffs2/Makefile.in
new file mode 100644
index 000000000..31452eba8
--- /dev/null
+++ b/target/jffs2/Makefile.in
@@ -0,0 +1,3 @@
+ifeq ($(strip $(BR2_TARGET_ROOTFS_JFFS2)),y)
+TARGETS+=jffs2root
+endif