summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMike Frysinger2005-08-07 10:30:24 +0200
committerMike Frysinger2005-08-07 10:30:24 +0200
commit5bfaa0bb404fb2342d7c34c37caa6f500e9f44b9 (patch)
treedeacb47cb47c8128de22be10d3665846c026a001 /target
parentuse the new gnuconfig stuff (diff)
downloadbuildroot-5bfaa0bb404fb2342d7c34c37caa6f500e9f44b9.tar.gz
buildroot-5bfaa0bb404fb2342d7c34c37caa6f500e9f44b9.tar.xz
buildroot-5bfaa0bb404fb2342d7c34c37caa6f500e9f44b9.zip
make sure ext2 target depends on fakeroot
Diffstat (limited to 'target')
-rw-r--r--target/ext2/ext2root.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index a934c5a5a..130ce2465 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -65,12 +65,14 @@ else
EXT2_TARGET := $(EXT2_BASE)
endif
-$(EXT2_BASE): genext2fs
+$(EXT2_BASE): host-fakeroot genext2fs
-@find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIP) 2>/dev/null || true;
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
- /sbin/ldconfig -r $(TARGET_DIR)
+ test -e "$(TARGET_DIR)/etc/ld.so.conf" \
+ && /sbin/ldconfig -r $(TARGET_DIR) \
+ || true
# Use fakeroot to pretend all target binaries are owned by root
$(STAGING_DIR)/usr/bin/fakeroot \
-i $(STAGING_DIR)/fakeroot.env \