summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPeter Korsgaard2010-06-22 17:41:34 +0200
committerPeter Korsgaard2010-06-22 17:41:34 +0200
commitb10197dcf2ca1d6afbdf8f131560a3a0a8b9c72d (patch)
tree4206d4c69790f60aa08864fdede35ed09e3b91e7 /target
parentpackage: remove games/Config.in (diff)
downloadbuildroot-b10197dcf2ca1d6afbdf8f131560a3a0a8b9c72d.tar.gz
buildroot-b10197dcf2ca1d6afbdf8f131560a3a0a8b9c72d.tar.xz
buildroot-b10197dcf2ca1d6afbdf8f131560a3a0a8b9c72d.zip
target: get rid of unused BR2_COPYTO / BR2_TARGET_ATMEL_COPYTO
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/Makefile.in48
-rw-r--r--target/device/Atmel/Config.in7
-rw-r--r--target/device/Atmel/Makefile.in6
3 files changed, 0 insertions, 61 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
index 8feb5644d..83dc4a5a0 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -1,54 +1,6 @@
BR2_PACKAGE_LINUX_FORMAT:=$(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT))
BR2_PACKAGE_LINUX_KCONFIG:=$(call qstrip,$(BR2_PACKAGE_LINUX_KCONFIG))
-
-# COPY_FILE absolute_path_to_file, target_directory, filename
-ifneq ($(call qstrip,$(BUILDROOT_COPYTO)),) # Use shell definition
-define COPY_FILE
- @echo "BUILDROOT_COPYTO: Copy to $(BUILDROOT_COPYTO)/$(strip $(3))" ; \
- mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
- if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
- cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi ; \
- mkdir -p $(BUILDROOT_COPYTO) || echo "Could not create $(BUILDROOT_COPYTO)" ; \
- if [ -d $(BUILDROOT_COPYTO) -o -w $(BUILDROOT_COPYTO) ] ; then \
- cp $(1) $(BUILDROOT_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi
-endef
-COPYTO=$(call qstrip,$(BUILDROOT_COPYTO))
-else
-ifneq ($(call qstrip,$(BR2_COPYTO)),) # Global override
-define COPY_FILE
- @echo "BR2_COPYTO: Copy to $(BR2_COPYTO)/$(strip $(3))" ; \
- mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
- if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
- cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi ; \
- if [ "$(call qstrip,$(BR2_COPYTO))X" != "X" ] ; then \
- mkdir -p $(BR2_COPYTO) || echo "Could not create $(BR2_COPYTO)" ; \
- if [ -d $(BR2_COPYTO) -o -w $(BR2_COPYTO) ] ; then \
- cp $(1) $(BR2_COPYTO)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi ; \
- fi
-endef
-COPYTO=$(call qstrip,$(BR2_COPYTO))
-else # Package specific copyto, or empty
-define COPY_FILE
- @echo "Copy to $(2)/$(strip $(3))" ; \
- mkdir -p $(BINARIES_DIR) || echo "Could not create $(BINARIES_DIR)" ; \
- if [ -w $(BINARIES_DIR) -o -w $(BINARIES_DIR) ] ; then \
- cp $(1) $(BINARIES_DIR)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi ; \
- if [ "$(call qstrip,$(2))X" != "X" ] ; then \
- mkdir -p $(2) || echo "Could not create $(2)" ; \
- if [ -d $(2) -o -w $(2) ] ; then \
- cp $(1) $(2)/$(strip $(3)) || echo "Could not copy $(3)" ; \
- fi ; \
- fi
-endef
-endif
-endif
-
# make sure to put everything that is board-specific before the tarroot targets
include target/generic/Makefile.in
diff --git a/target/device/Atmel/Config.in b/target/device/Atmel/Config.in
index 870c537d1..1433af486 100644
--- a/target/device/Atmel/Config.in
+++ b/target/device/Atmel/Config.in
@@ -50,13 +50,6 @@ config BR2_AT91_LINUXPATCH_SITE
help
Main download location for AT91 Linux stuff
-config BR2_TARGET_ATMEL_COPYTO
- string "also copy the image to..."
- depends on BR2_TARGET_AT91 || BR2_TARGET_AVR32
- default "/tftpboot"
- help
- Copies the resulting image to a secondary location.
-
config BR2_BOARD_PATH
string "Atmel board repository"
depends on BR2_TARGET_AT91 || BR2_TARGET_AVR32
diff --git a/target/device/Atmel/Makefile.in b/target/device/Atmel/Makefile.in
index 6de54d7a9..38060aae4 100644
--- a/target/device/Atmel/Makefile.in
+++ b/target/device/Atmel/Makefile.in
@@ -14,12 +14,6 @@ ifeq ($(BR2_avr32),y)
KERNEL_HEADERS_PATCH_DIR=target/device/Atmel/arch-avr32/kernel-headers-2.6.28.2
endif
-ifneq ($(COPYTO),)
-TARGET_ATMEL_COPYTO:=$(call qstrip,$(BR2_COPYTO))
-else
-TARGET_ATMEL_COPYTO:=$(call qstrip,$(BR2_TARGET_ATMEL_COPYTO))
-endif
-
# These are set by Config.in
DOWNLOAD_LINUX26_VERSION:= $(call qstrip,$(BR2_DOWNLOAD_LINUX26_VERSION))
ifeq ($(DOWNLOAD_LINUX26_VERSION),)