summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorEric Andersen2005-06-24 05:14:20 +0200
committerEric Andersen2005-06-24 05:14:20 +0200
commite83529ad36233a604b165de9c31d56137651302b (patch)
treed686e5742effeb61f53a88637e9cbcafdf990426 /target
parentThis patch adds package configuration files for the LVM2 tools and its (diff)
downloadbuildroot-e83529ad36233a604b165de9c31d56137651302b.tar.gz
buildroot-e83529ad36233a604b165de9c31d56137651302b.tar.xz
buildroot-e83529ad36233a604b165de9c31d56137651302b.zip
mksquashfs is always rebuilt before generating rootfs image. The attached
patch avoids this issue, by creating a .unpacked file in the squashfs directory after the source tarball is unpacked, and making the mksquashfs target depend on the .unpacked file. http://bugs.busybox.net/view.php?id=234
Diffstat (limited to 'target')
-rw-r--r--target/squashfs/squashfsroot.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/squashfs/squashfsroot.mk b/target/squashfs/squashfsroot.mk
index d969efed0..300e07091 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/target/squashfs/squashfsroot.mk
@@ -10,11 +10,12 @@ SQUASHFS_SITE=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/sq
$(DL_DIR)/$(SQUASHFS_SOURCE):
$(WGET) -P $(DL_DIR) $(SQUASHFS_SITE)/$(SQUASHFS_SOURCE)
-$(SQUASHFS_DIR): $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
+$(SQUASHFS_DIR)/.unpacked: $(DL_DIR)/$(SQUASHFS_SOURCE) #$(SQUASHFS_PATCH)
zcat $(DL_DIR)/$(SQUASHFS_SOURCE) | tar -C $(BUILD_DIR) -xvf -
toolchain/patch-kernel.sh $(SQUASHFS_DIR) target/squashfs/ squashfs.patch
+ touch $(SQUASHFS_DIR)/.unpacked
-$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)
+$(SQUASHFS_DIR)/squashfs-tools/mksquashfs: $(SQUASHFS_DIR)/.unpacked
$(MAKE) -C $(SQUASHFS_DIR)/squashfs-tools;
squashfs: $(SQUASHFS_DIR)/squashfs-tools/mksquashfs