summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer2007-03-22 19:14:23 +0100
committerBernhard Reutner-Fischer2007-03-22 19:14:23 +0100
commite96908633df72889603c504a22fc988f5cb77bed (patch)
treecc94bb238739228a20dbe6a9ee94246b3c31fde9 /target
parent- see if the dir exists before trying to strip an empty list of files.. (diff)
downloadbuildroot-e96908633df72889603c504a22fc988f5cb77bed.tar.gz
buildroot-e96908633df72889603c504a22fc988f5cb77bed.tar.xz
buildroot-e96908633df72889603c504a22fc988f5cb77bed.zip
- add a question for andersee
Diffstat (limited to 'target')
-rw-r--r--target/linux26.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux26.mk b/target/linux26.mk
index ab017ff3a..e5d3d920a 100644
--- a/target/linux26.mk
+++ b/target/linux26.mk
@@ -8,6 +8,7 @@ ifneq ($(filter $(TARGETS),linux26),)
ifeq ($(LINUX_HEADERS_VERSION),)
# Version of Linux to download and then apply patches to
+# XXX: andersee, i do not understand why we need this (BF)
DOWNLOAD_LINUX26_VERSION=2.6.19.2
# Version of Linux after applying any patches
LINUX26_VERSION=2.6.19.2
@@ -70,7 +71,7 @@ $(LINUX26_DIR)/.unpacked: $(DL_DIR)/$(LINUX26_SOURCE)
$(LINUX26_BZCAT) $(DL_DIR)/$(LINUX26_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(DOWNLOAD_LINUX26_VERSION),$(LINUX26_VERSION))
# Rename the dir from the downloaded version to the AFTER patch version
- mv -f $(BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(BUILD_DIR)/linux-$(LINUX26_VERSION)
+ mv -f $(BUILD_DIR)/linux-$(DOWNLOAD_LINUX26_VERSION) $(LINUX26_DIR)
endif
touch $@