summaryrefslogtreecommitdiffstats
path: root/toolchain/Config.in.2
diff options
context:
space:
mode:
authorDaniel Laird2009-01-30 17:28:26 +0100
committerDaniel Laird2009-01-30 17:28:26 +0100
commit040bd64849da37e6c35bab3726019c059c96893e (patch)
treef32407351911c80dd455479e5fc2dbc27f77e211 /toolchain/Config.in.2
parenttarget/linux/Makefile.in.advanced: get rid of BUILDROOT_USE_XWINDOWS (diff)
downloadbuildroot-040bd64849da37e6c35bab3726019c059c96893e.tar.gz
buildroot-040bd64849da37e6c35bab3726019c059c96893e.tar.xz
buildroot-040bd64849da37e6c35bab3726019c059c96893e.zip
Extend External Toolchain options (match buildroot built toolchain):
Have added options that mean you can set the same BR2_XXXX variables for external toolchain and internal (buildroot built) toolchain. This means the same set of packages can be built now me as for you..... Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
Diffstat (limited to 'toolchain/Config.in.2')
-rw-r--r--toolchain/Config.in.2117
1 files changed, 96 insertions, 21 deletions
diff --git a/toolchain/Config.in.2 b/toolchain/Config.in.2
index 9fbe60c14..6daca62d8 100644
--- a/toolchain/Config.in.2
+++ b/toolchain/Config.in.2
@@ -1,35 +1,56 @@
#
-
-if BR2_TOOLCHAIN_SOURCE
-source "toolchain/elf2flt/Config.in"
-source "toolchain/mklibs/Config.in"
-source "toolchain/sstrip/Config.in"
-
-config BR2_ENABLE_MULTILIB
- bool "Enable multilib support?"
- help
- Build libraries to support different ABIs.
-
config BR2_LARGEFILE
bool "Enable large file (files > 2 GB) support?"
depends on !BR2_cris
help
- Enable large file (files > 2 GB) support
+ If you are building your own toolchain and you want to
+ support files larger than 2GB then enable this option.
+ If you have an external binary toolchain that has been
+ built with large file support (files > 2GB) then enable
+ this option.
config BR2_INET_IPV6
bool "Enable IPv6"
help
- Enable IPv6.
+ If you are building your own toolchain and you want to
+ enable IPV6 support then enable this option.
+ If you have an external binary toolchain that has been
+ built with IPV6 support then enable this option.
config BR2_INET_RPC
bool "Enable RPC"
help
- Enable RPC. RPC support is needed for nfs.
+ Enable RPC. RPC support is needed for nfs.
+ If you are building your own toolchain and you want to
+ enable RPC support then enable this option.
+ If you have an external binary toolchain that has been
+ built with RPC support then enable this option.
+
+config BR2_ENABLE_LOCALE
+ bool "Enable locale/gettext/i18n support?"
+ help
+ If you are building your own toolchain and you want to
+ enable locale/gettext/i18n support then enable this option.
+ If you have an external binary toolchain that has been
+ built with locale/gettext/i18n support then enable this option.
+
+config BR2_ENABLE_LOCALE_PREGENERATED
+ bool "Use pregenerated locale data?"
+ depends on BR2_ENABLE_LOCALE && BR2_TOOLCHAIN_SOURCE
+ help
+ Instead of generating the locale data locally you can optionally
+ download a pregenerated set of locales.
+
+ Say N here unless your buildhost lacks locale support and you
+ desparately want to use internationalization on your target.
config BR2_USE_WCHAR
bool "Enable WCHAR support"
help
- Enable WCHAR. WCHAR support is needed for several packages
+ If you are building your own toolchain and you want to
+ enable WCHAR support then enable this option.
+ If you have an external binary toolchain that has been built
+ with WCHAR support then enable this option.
config BR2_SOFT_FLOAT
bool "Use software floating point by default"
@@ -42,6 +63,66 @@ config BR2_SOFT_FLOAT
Most people will answer N.
+choice
+ prompt "Thread library implementation"
+ default BR2_PTHREADS_OLD
+ help
+ If you are building your own toolchain then select the type of
+ libpthreads you want to use.
+ Not all thread variants work with all versions of uClibc,
+ the "linuxthreads (stable/old)" may be a working fallback
+ if you need threading at all.
+ If you have an external binary toolchain then select the type
+ of libpthreads it was built with.
+
+ config BR2_PTHREADS_NONE
+ bool "none"
+
+ config BR2_PTHREADS
+ bool "linuxthreads"
+
+ config BR2_PTHREADS_OLD
+ bool "linuxthreads (stable/old)"
+
+ config BR2_PTHREADS_NATIVE
+ bool "Native POSIX Threading (NPTL)"
+endchoice
+
+config BR2_GCC_CROSS_CXX
+ bool
+ help
+ If you are building your own toolchain and want to build
+ a C++ cross-compiler this needs to be enabled.
+ If you have an external binary toolchain that has a C++ compiler
+ and you want to use it then you need to enable this option.
+
+config BR2_INSTALL_LIBSTDCPP
+ bool "Build/install c++ compiler and libstdc++?"
+ select BR2_LARGEFILE if (!BR2_GCC_SUPPORTS_SYSROOT && BR2_TOOLCHAIN_SOURCE)
+ select BR2_GCC_CROSS_CXX
+ help
+ If you are building your own toolchain and want to build and install
+ the C++ compiler and library then you need to enable this option.
+ If you have an external toolchain that has been built with C++
+ support and you want to use the compiler / library then you need
+ to select this option.
+
+config BR2_TARGET_OPTIMIZATION
+ string "Target Optimizations"
+ default "-Os -pipe"
+ help
+ Optimizations to use when building for the target host.
+
+if BR2_TOOLCHAIN_SOURCE
+source "toolchain/elf2flt/Config.in"
+source "toolchain/mklibs/Config.in"
+source "toolchain/sstrip/Config.in"
+
+config BR2_ENABLE_MULTILIB
+ bool "Enable multilib support?"
+ help
+ Build libraries to support different ABIs.
+
config BR2_VFP_FLOAT
bool "Use ARM Vector Floating Point unit"
depends on !BR2_SOFT_FLOAT
@@ -54,12 +135,6 @@ config BR2_VFP_FLOAT
Most people will answer N.
-config BR2_TARGET_OPTIMIZATION
- string "Target Optimizations"
- default "-Os -pipe"
- help
- Optimizations to use when building for the target host.
-
config BR2_CROSS_TOOLCHAIN_TARGET_UTILS
bool "Include target utils in cross toolchain"
default y