summaryrefslogtreecommitdiffstats
path: root/toolchain/binutils
diff options
context:
space:
mode:
authorMartin Banky2010-11-03 19:59:31 +0100
committerPeter Korsgaard2010-11-04 20:16:28 +0100
commit4af6496eac1146a2eceb3e4c9915307a9e69b9e6 (patch)
tree18ed54d1d230b12030468dbea225eadbf54706f3 /toolchain/binutils
parentUpdate uclibc snapshot config to avoid build stall (diff)
downloadbuildroot-4af6496eac1146a2eceb3e4c9915307a9e69b9e6.tar.gz
buildroot-4af6496eac1146a2eceb3e4c9915307a9e69b9e6.tar.xz
buildroot-4af6496eac1146a2eceb3e4c9915307a9e69b9e6.zip
Add gcc 4.5.1 to buildroot
Signed-off-by: Martin.Banky@gmail.com <Martin.Banky@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/binutils')
-rw-r--r--toolchain/binutils/binutils.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/toolchain/binutils/binutils.mk b/toolchain/binutils/binutils.mk
index 85b605ea1..ef9f64404 100644
--- a/toolchain/binutils/binutils.mk
+++ b/toolchain/binutils/binutils.mk
@@ -29,6 +29,22 @@ EXTRA_BINUTILS_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_HOST_DIR)"
BINUTILS_TARGET_CONFIG_OPTIONS=--with-gmp="$(GMP_TARGET_DIR)"
BINUTILS_TARGET_CONFIG_OPTIONS+=--with-mpfr="$(MPFR_TARGET_DIR)"
+ifeq ($(BR2_PACKAGE_LIBMPC),y)
+BINUTILS_ADD_MPC = y
+endif
+
+ifeq ($(findstring x4.5.,x$(GCC_VERSION)),x4.5.)
+BINUTILS_ADD_MPC = y
+endif
+
+ifeq ($(BINUTILS_ADD_MPC),y)
+BINUTILS_HOST_PREREQ += $(TOOLCHAIN_DIR)/mpc/lib/libmpc$(HOST_LIBEXT)
+HOST_SOURCE += host-libmpc-source
+BINUTILS_TARGET_PREREQ += $(TARGET_DIR)/usr/lib/libmpc$(LIBTGTEXT)
+EXTRA_BINUTILS_CONFIG_OPTIONS += --with-mpc="$(MPC_HOST_DIR)"
+BINUTILS_TARGET_CONFIG_OPTIONS += --with-mpc="$(MPC_TARGET_DIR)"
+endif
+
BINUTILS_PATCH_DIR:=toolchain/binutils/$(BINUTILS_VERSION)
ifneq ($(filter xtensa%,$(ARCH)),)