summaryrefslogtreecommitdiffstats
path: root/toolchain/ccache/ccache.mk
diff options
context:
space:
mode:
authorMichael Roth2009-09-23 01:30:00 +0200
committerPeter Korsgaard2009-09-23 09:15:27 +0200
commitcb5710c538fce01f4875a64e6de4b37a7718005b (patch)
treec1ebe4a0dbbbe4c5a24f7cc765854b90e3a585df /toolchain/ccache/ccache.mk
parentChange the default BR2_DL_DIR location (diff)
downloadbuildroot-cb5710c538fce01f4875a64e6de4b37a7718005b.tar.gz
buildroot-cb5710c538fce01f4875a64e6de4b37a7718005b.tar.xz
buildroot-cb5710c538fce01f4875a64e6de4b37a7718005b.zip
rename TOOL_BUILD_DIR to TOOLCHAIN_DIR
To reflect the new output directory hierachy rename the Makefile variable TOOL_BUILD_DIR to TOOLCHAIN_DIR. Signed-off-by: Michael Roth <mroth@nessie.de> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/ccache/ccache.mk')
-rw-r--r--toolchain/ccache/ccache.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/ccache/ccache.mk b/toolchain/ccache/ccache.mk
index 723b8719f..43ed2a773 100644
--- a/toolchain/ccache/ccache.mk
+++ b/toolchain/ccache/ccache.mk
@@ -6,7 +6,7 @@
CCACHE_VER:=2.4
CCACHE_SITE:=http://samba.org/ftp/ccache
CCACHE_SOURCE:=ccache-$(CCACHE_VER).tar.gz
-CCACHE_DIR1:=$(TOOL_BUILD_DIR)/ccache-$(CCACHE_VER)
+CCACHE_DIR1:=$(TOOLCHAIN_DIR)/ccache-$(CCACHE_VER)
CCACHE_DIR2:=$(BUILD_DIR)/ccache-$(CCACHE_VER)
CCACHE_CAT:=$(ZCAT)
CCACHE_BINARY:=ccache
@@ -16,7 +16,7 @@ $(DL_DIR)/$(CCACHE_SOURCE):
$(call DOWNLOAD,$(CCACHE_SITE),$(CCACHE_SOURCE))
$(CCACHE_DIR1)/.unpacked: $(DL_DIR)/$(CCACHE_SOURCE)
- $(CCACHE_CAT) $(DL_DIR)/$(CCACHE_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
+ $(CCACHE_CAT) $(DL_DIR)/$(CCACHE_SOURCE) | tar -C $(TOOLCHAIN_DIR) $(TAR_OPTIONS) -
touch $@
$(CCACHE_DIR1)/.patched: $(CCACHE_DIR1)/.unpacked