summaryrefslogtreecommitdiffstats
path: root/toolchain/external-toolchain/ext-tool.mk
diff options
context:
space:
mode:
authorYann E. MORIN2010-05-28 23:23:14 +0200
committerPeter Korsgaard2010-05-28 23:31:15 +0200
commitb6e67cc3639937c45e0b7e25f830792854dd4ffb (patch)
tree3c87d0ae28ab2715f7b9661b165328adf5f4270c /toolchain/external-toolchain/ext-tool.mk
parentCHANGES: xserver-xorg has been changed (diff)
downloadbuildroot-b6e67cc3639937c45e0b7e25f830792854dd4ffb.tar.gz
buildroot-b6e67cc3639937c45e0b7e25f830792854dd4ffb.tar.xz
buildroot-b6e67cc3639937c45e0b7e25f830792854dd4ffb.zip
toolchain/external: only copy the pthread lib if needed
If threads are disabled, do not try to copy the libpthread.so from the external library. It is still expected that the BR configuration matches the external toolchain setup, and no check is done to enforce that. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/external-toolchain/ext-tool.mk')
-rw-r--r--toolchain/external-toolchain/ext-tool.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/toolchain/external-toolchain/ext-tool.mk b/toolchain/external-toolchain/ext-tool.mk
index bb4809ccd..e858edb8c 100644
--- a/toolchain/external-toolchain/ext-tool.mk
+++ b/toolchain/external-toolchain/ext-tool.mk
@@ -251,7 +251,7 @@ check_cross_compiler_exists = \
uclibc: dependencies $(STAMP_DIR)/ext-toolchain-installed
-EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthread.so libresolv.so librt.so libutil.so
+EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libresolv.so librt.so libutil.so
ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
EXTERNAL_LIBS+=ld-uClibc.so
else
@@ -262,6 +262,10 @@ ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
EXTERNAL_LIBS+=libstdc++.so
endif
+ifneq ($(BR2_PTHREADS_NONE),y)
+EXTERNAL_LIBS+=libpthread.so
+endif # ! no threads
+
# SYSROOT_DIR selection. We first try the -print-sysroot option,
# available in gcc 4.4.x and in some Codesourcery toolchains. If this
# option is not available, we fallback to the value of --with-sysroot