summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/Config.in
diff options
context:
space:
mode:
authorThomas Petazzoni2009-12-14 12:15:36 +0100
committerThomas Petazzoni2009-12-14 23:54:42 +0100
commitd3f383b1eeafa11b093d7a5626d375d07ed2c3d7 (patch)
treea3c4343feb014fa957fd265eb1f7980b317e7283 /toolchain/gcc/Config.in
parentbinutils: add avr32 special version (diff)
downloadbuildroot-d3f383b1eeafa11b093d7a5626d375d07ed2c3d7.tar.gz
buildroot-d3f383b1eeafa11b093d7a5626d375d07ed2c3d7.tar.xz
buildroot-d3f383b1eeafa11b093d7a5626d375d07ed2c3d7.zip
gcc: add avr32 special version
* Add new gcc version 4.2.2-avr32-2.1.5 in Config.in * Select the Atmel mirror to download gcc with avr32 in their version name, in gcc-uclibc-*.mk * Do not apply patches if the patch directory is empty, in gcc-uclibc-*.mk Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gcc/Config.in')
-rw-r--r--toolchain/gcc/Config.in7
1 files changed, 6 insertions, 1 deletions
diff --git a/toolchain/gcc/Config.in b/toolchain/gcc/Config.in
index 7e5851620..3d3da46ec 100644
--- a/toolchain/gcc/Config.in
+++ b/toolchain/gcc/Config.in
@@ -26,6 +26,10 @@ choice
depends on BR2_DEPRECATED || BR2_avr32
bool "gcc 4.2.2"
+ config BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
+ depends on BR2_avr32
+ bool "gcc 4.2.2-avr32-2.1.5"
+
config BR2_GCC_VERSION_4_2_3
depends on !BR2_nios2
depends on BR2_EXT_GCC_VERSION_4_2_3
@@ -66,7 +70,7 @@ config BR2_GCC_SUPPORTS_SYSROOT
config BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE
bool
- default y if !BR2_GCC_VERSION_4_1_2 && !BR2_GCC_VERSION_4_2_1 && !BR2_GCC_VERSION_4_2_2 && !BR2_GCC_VERSION_4_2_3 && !BR2_GCC_VERSION_4_2_4
+ default y if !BR2_GCC_VERSION_4_1_2 && !BR2_GCC_VERSION_4_2_1 && !BR2_GCC_VERSION_4_2_2 && !BR2_GCC_VERSION_4_2_3 && !BR2_GCC_VERSION_4_2_4 && !BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
config BR2_GCC_SNAP_DATE
string "GCC snapshot date"
@@ -81,6 +85,7 @@ config BR2_GCC_VERSION
default "4.1.2" if BR2_GCC_VERSION_4_1_2
default "4.2.1" if BR2_GCC_VERSION_4_2_1
default "4.2.2" if BR2_GCC_VERSION_4_2_2
+ default "4.2.2-avr32-2.1.5" if BR2_GCC_VERSION_4_2_2_AVR32_2_1_5
default "4.2.3" if BR2_GCC_VERSION_4_2_3
default "4.2.4" if BR2_GCC_VERSION_4_2_4
default "4.3.2" if BR2_GCC_VERSION_4_3_2