summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorHans-Christian Egtvedt2008-10-02 16:32:07 +0200
committerHans-Christian Egtvedt2008-10-02 16:32:07 +0200
commit3fac2be7243fbfeed1fac63d2baee601f18cc87e (patch)
treeeb197d9ccba8c988ffd0ec5bcf3c7a8e6b0cab5e /toolchain/gcc/gcc-uclibc-4.x.mk
parentkernel-headers: remove whitespace damage (diff)
downloadbuildroot-3fac2be7243fbfeed1fac63d2baee601f18cc87e.tar.gz
buildroot-3fac2be7243fbfeed1fac63d2baee601f18cc87e.tar.xz
buildroot-3fac2be7243fbfeed1fac63d2baee601f18cc87e.zip
gcc: make sure that /usr/lib exists on target before installing shared libs
On very lite systems the /usr/lib directory might not exist before libstdc++ is installed. This patch makes sure the directory exists. Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 698069c2c..668e9fc1f 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -369,6 +369,7 @@ ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
endif
ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
ifeq ($(BR2_GCC_SHARED_LIBGCC),y)
+ mkdir -p $(TARGET_DIR)/usr/lib
-cp -dpf $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/lib/libstdc++.so* \
$(TARGET_DIR)/usr/lib/
-$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libstdc++.so*