summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2009-01-30 14:34:42 +0100
committerPeter Korsgaard2009-01-30 14:34:42 +0100
commit92bd25c9eb14eafb1beb8f41af71fef1e545922a (patch)
tree6574d5baaa0bcf3d9c02287c75d020932674e5bd /toolchain/gcc/gcc-uclibc-4.x.mk
parenttoolchain/gcc: remove unused gcc 3.x cruft from 4.x makefile (sysroot) (diff)
downloadbuildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.tar.gz
buildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.tar.xz
buildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.zip
toolchain: fix up GNU_TARGET_NAME link and target_utils location
The GNU_TARGET_NAME symlink and target_utils location were not correctly adjusted to match the move of the toolchain to $(STAGING_DIR)/usr, creating dangling symlinks.
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index d0d3ae316..c4ef41a9d 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -319,14 +319,14 @@ endif
ln -snf $(REAL_GNU_TARGET_NAME)-gcc \
$(STAGING_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-cc; \
fi
- if [ ! -e $(STAGING_DIR)/usr/bin/cc ]; then \
- ln -snf gcc $(STAGING_DIR)/usr/bin/cc; \
+ if [ ! -e $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin/cc ]; then \
+ ln -snf gcc $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin/cc; \
fi
# Set up the symlinks to enable lying about target name.
set -e; \
- (cd $(STAGING_DIR); \
+ (cd $(STAGING_DIR)/usr; \
ln -snf $(REAL_GNU_TARGET_NAME) $(GNU_TARGET_NAME); \
- cd usr/bin; \
+ cd bin; \
for app in $(REAL_GNU_TARGET_NAME)-*; do \
ln -snf $${app} \
$(GNU_TARGET_NAME)$${app##$(REAL_GNU_TARGET_NAME)}; \