summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc/gcc-uclibc-4.x.mk
diff options
context:
space:
mode:
authorAngus Salkeld2009-05-05 22:04:52 +0200
committerPeter Korsgaard2009-05-12 10:02:20 +0200
commitbb1f42e4426c432af60fc80da45c6daf7e31c1a0 (patch)
treeaeb97452a1a888658387bccbcadf49e1645c2480 /toolchain/gcc/gcc-uclibc-4.x.mk
parentkernel-headers: bump 2.6.27 / 2.6.29 versions (diff)
downloadbuildroot-bb1f42e4426c432af60fc80da45c6daf7e31c1a0.tar.gz
buildroot-bb1f42e4426c432af60fc80da45c6daf7e31c1a0.tar.xz
buildroot-bb1f42e4426c432af60fc80da45c6daf7e31c1a0.zip
gcc-4.3.3: add a patch to link with the math lib to get copysignal
Conditionally apply the following patch by Bernhard Reutner-Fischer which solves a link error on powerpc (with softfloat or multilib) when using a shared libgcc_s. See: http://gcc.gnu.org/ml/gcc-patches/2008-10/msg00237.html http://www.nabble.com/PPC-won't-build-with-soft-float-td22772110.html Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc/gcc-uclibc-4.x.mk')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 8ecd97ad0..f7dd40af4 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -179,6 +179,11 @@ ifeq ("$(strip $(ARCH))","armeb")
toolchain/patch-kernel.sh $(GCC_DIR) toolchain/gcc/$(GCC_VERSION) arm-softfloat.patch.conditional
endif
endif
+ifeq ($(ARCH)-$(BR2_GCC_SHARED_LIBGCC),powerpc-y)
+ifneq ($(BR2_SOFT_FLOAT)$(BR2_ENABLE_MULTILIB),)
+ toolchain/patch-kernel.sh $(GCC_DIR) toolchain/gcc/$(GCC_VERSION) powerpc-link-with-math-lib.patch.conditional
+endif
+endif
touch $@
#############################################################