summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorThomas Petazzoni2010-07-22 15:42:27 +0200
committerThomas Petazzoni2010-07-27 22:56:36 +0200
commit2ae84ac85ff72a861e8c276ba4e650e1e9ba7982 (patch)
tree91c50ef57f22f04eade4bf7c2b5338a1e8ec95ea /toolchain/gcc
parentMerge branch 'fix-gxx-on-target' of git://git.busybox.net/~tpetazzoni/git/bui... (diff)
downloadbuildroot-2ae84ac85ff72a861e8c276ba4e650e1e9ba7982.tar.gz
buildroot-2ae84ac85ff72a861e8c276ba4e650e1e9ba7982.tar.xz
buildroot-2ae84ac85ff72a861e8c276ba4e650e1e9ba7982.zip
binutils,gcc: use correct --prefix
The cross binutils and cross gcc are actually going to be executed from $(STAGING_DIR)/usr, so the correct prefix is $(STAGING_DIR)/usr and not /usr. This also fixes what is known as the "AVR32 toolchain build failure", which was due to the fact that the prefix directory wasn't writable (since it was /usr). Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/gcc-uclibc-4.x.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gcc/gcc-uclibc-4.x.mk b/toolchain/gcc/gcc-uclibc-4.x.mk
index 6e767ac77..0a538dec0 100644
--- a/toolchain/gcc/gcc-uclibc-4.x.mk
+++ b/toolchain/gcc/gcc-uclibc-4.x.mk
@@ -266,7 +266,7 @@ $(GCC_BUILD_DIR2)/.configured: $(GCC_SRC_DIR)/.patched $(GCC_STAGING_PREREQ)
(cd $(GCC_BUILD_DIR2); rm -rf config.cache; \
$(HOST_CONFIGURE_OPTS) \
$(GCC_SRC_DIR)/configure $(QUIET) \
- --prefix=/usr \
+ --prefix=$(STAGING_DIR)/usr \
--build=$(GNU_HOST_NAME) \
--host=$(GNU_HOST_NAME) \
--target=$(REAL_GNU_TARGET_NAME) \
@@ -299,7 +299,7 @@ $(GCC_BUILD_DIR2)/.compiled: $(GCC_BUILD_DIR2)/.configured
touch $@
$(GCC_BUILD_DIR2)/.installed: $(GCC_BUILD_DIR2)/.compiled
- PATH=$(TARGET_PATH) $(MAKE) $(BR2_SYSROOT_STAGING_DESTDIR) \
+ PATH=$(TARGET_PATH) $(MAKE) \
-C $(GCC_BUILD_DIR2) install
if [ -d "$(STAGING_DIR)/lib64" ]; then \
if [ ! -e "$(STAGING_DIR)/lib" ]; then \