summaryrefslogtreecommitdiffstats
path: root/toolchain/gcc
diff options
context:
space:
mode:
authorGustavo Zacarias2012-01-05 20:31:43 +0100
committerPeter Korsgaard2012-01-07 20:46:11 +0100
commit5a6087d62e5c2a272278606ebf1cc62830cf4c68 (patch)
tree965b155a8b887704f2d321e544c183152d4a5fb5 /toolchain/gcc
parentxenomai: mention which kernel versions are supported (diff)
downloadbuildroot-5a6087d62e5c2a272278606ebf1cc62830cf4c68.tar.gz
buildroot-5a6087d62e5c2a272278606ebf1cc62830cf4c68.tar.xz
buildroot-5a6087d62e5c2a272278606ebf1cc62830cf4c68.zip
toolchain: add powerpc SPE ABI support
Add the ability for buildroot to build an SPE ABI enabled toolchain. This is mandatory for e500v1/v2 cores since they don't support classic FPU mode as the e500mc does. Useful for Freescale's PowerQUICC III and single/dual-core QorIQ line of processors. The new TARGET_ABI variable is used rather than TARGET_CFLAGS for uclibc's UCLIBC_EXTRA_CFLAGS to avoid breakish CFLAGS leaking in, a good example being -mthumb for ARM. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/gcc')
-rw-r--r--toolchain/gcc/Makefile.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/toolchain/gcc/Makefile.in b/toolchain/gcc/Makefile.in
index 2e55ed0f7..d9efcf063 100644
--- a/toolchain/gcc/Makefile.in
+++ b/toolchain/gcc/Makefile.in
@@ -47,6 +47,11 @@ EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap
SOFT_FLOAT_CONFIG_OPTION:=
endif
+# Disable mudflap and enable proper double/long double for SPE ABI
+ifeq ($(BR2_powerpc_SPE),y)
+EXTRA_GCC_CONFIG_OPTIONS+=--disable-libmudflap --enable-e500_double --with-long-double-128
+endif
+
ifeq ($(BR2_PACKAGE_GCC_TARGET),y)
EXTRA_TARGET_GCC_CONFIG_OPTIONS:=