summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/gdb.mk
diff options
context:
space:
mode:
authorMike Frysinger2005-12-02 23:31:12 +0100
committerMike Frysinger2005-12-02 23:31:12 +0100
commit2ed0efef422a52d8c4f0e6be1b06ee674819e757 (patch)
tree3949569786a6f9ab41016da7b9bf2d30994bec19 /toolchain/gdb/gdb.mk
parent- fixed in 4.0.3 and 4.1.0 (diff)
downloadbuildroot-2ed0efef422a52d8c4f0e6be1b06ee674819e757.tar.gz
buildroot-2ed0efef422a52d8c4f0e6be1b06ee674819e757.tar.xz
buildroot-2ed0efef422a52d8c4f0e6be1b06ee674819e757.zip
import gdb-6.4
Diffstat (limited to 'toolchain/gdb/gdb.mk')
-rw-r--r--toolchain/gdb/gdb.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 6ae6fab36..af67b7434 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -26,6 +26,7 @@ endif
$(DL_DIR)/$(GDB_SOURCE):
$(WGET) -P $(DL_DIR) $(GDB_SITE)/$(GDB_SOURCE)
+gdb-unpacked: $(GDB_DIR)/.unpacked
$(GDB_DIR)/.unpacked: $(DL_DIR)/$(GDB_SOURCE)
$(GDB_CAT) $(DL_DIR)/$(GDB_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
ifeq ($(GDB_VERSION),snapshot)
@@ -39,6 +40,9 @@ endif
# Should probably integrate this into the patch.
touch $(GDB_DIR)/.unpacked
+gdb-dirclean:
+ rm -rf $(GDB_DIR)
+
######################################################################
#
# gdb target