summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb/gdb.mk
diff options
context:
space:
mode:
authorEric Andersen2005-01-23 12:09:40 +0100
committerEric Andersen2005-01-23 12:09:40 +0100
commit7be239c03f7b5366ad0c4c118955492c1529861c (patch)
treee5976de2891d3ac1c1b912b80aed5c9e484cc82f /toolchain/gdb/gdb.mk
parentBump version to 1.28, per recommendation from solar (diff)
downloadbuildroot-7be239c03f7b5366ad0c4c118955492c1529861c.tar.gz
buildroot-7be239c03f7b5366ad0c4c118955492c1529861c.tar.xz
buildroot-7be239c03f7b5366ad0c4c118955492c1529861c.zip
Patch from acmay: http://bugs.uclibc.org/view.php?id=50
0000050: gdb_server and gdb_client fixes and split Here is a patch with 2 issues. gdbserver does not depend on ncurses (just the full gdb needs it) Split out gdb client config option, to be separate from gdbserver. If you build gdb client for the host once it does not need to be rebuilt when the rest of libs change. So I build it and save it off.
Diffstat (limited to 'toolchain/gdb/gdb.mk')
-rw-r--r--toolchain/gdb/gdb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 862f84d7f..7c3c8deaa 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -135,7 +135,7 @@ $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
$(TARGET_DIR)/usr/bin/gdbserver: $(GDB_SERVER_DIR)/gdbserver
install -c $(GDB_SERVER_DIR)/gdbserver $(TARGET_DIR)/usr/bin/gdbserver
-gdbserver: ncurses-headers $(TARGET_DIR)/usr/bin/gdbserver
+gdbserver: $(TARGET_DIR)/usr/bin/gdbserver
gdbserver-clean:
$(MAKE) -C $(GDB_SERVER_DIR) clean