summaryrefslogtreecommitdiffstats
path: root/toolchain/gdb
diff options
context:
space:
mode:
authorThomas Petazzoni2010-07-06 09:27:32 +0200
committerThomas Petazzoni2010-07-07 08:20:21 +0200
commita1c8fa41f6f6e5047182fe90656bcd30243bca8d (patch)
treecf1b67669365d0aabc1756fa5ffab71cbeaea571 /toolchain/gdb
parentexternal-toolchain: adjust tests on TARGET_CC and TARGET_CXX (diff)
downloadbuildroot-a1c8fa41f6f6e5047182fe90656bcd30243bca8d.tar.gz
buildroot-a1c8fa41f6f6e5047182fe90656bcd30243bca8d.tar.xz
buildroot-a1c8fa41f6f6e5047182fe90656bcd30243bca8d.zip
Update all packages to quote $(TARGET_CC)
Now that TARGET_CC contains several space-separated words, it must be used quoted everywhere. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/gdb')
-rw-r--r--toolchain/gdb/gdb.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/gdb/gdb.mk b/toolchain/gdb/gdb.mk
index 5725067c2..c4fef8946 100644
--- a/toolchain/gdb/gdb.mk
+++ b/toolchain/gdb/gdb.mk
@@ -95,7 +95,7 @@ endif
$(GDB_TARGET_DIR)/gdb/gdb: $(GDB_TARGET_DIR)/.configured
# force ELF support since it fails due to BFD linking problems
gdb_cv_var_elf=yes \
- $(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
+ $(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_TARGET_DIR)
$(STRIPCMD) $(GDB_TARGET_DIR)/gdb/gdb
@@ -150,7 +150,7 @@ $(GDB_SERVER_DIR)/.configured: $(GDB_DIR)/.unpacked
touch $@
$(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
- $(MAKE) CC=$(TARGET_CC) MT_CFLAGS="$(TARGET_CFLAGS)" \
+ $(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
-C $(GDB_SERVER_DIR)
$(STRIPCMD) $(GDB_SERVER_DIR)/gdbserver