summaryrefslogtreecommitdiffstats
path: root/toolchain/uClibc/uclibc.mk
diff options
context:
space:
mode:
authorPeter Korsgaard2009-01-30 14:34:42 +0100
committerPeter Korsgaard2009-01-30 14:34:42 +0100
commit92bd25c9eb14eafb1beb8f41af71fef1e545922a (patch)
tree6574d5baaa0bcf3d9c02287c75d020932674e5bd /toolchain/uClibc/uclibc.mk
parenttoolchain/gcc: remove unused gcc 3.x cruft from 4.x makefile (sysroot) (diff)
downloadbuildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.tar.gz
buildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.tar.xz
buildroot-92bd25c9eb14eafb1beb8f41af71fef1e545922a.zip
toolchain: fix up GNU_TARGET_NAME link and target_utils location
The GNU_TARGET_NAME symlink and target_utils location were not correctly adjusted to match the move of the toolchain to $(STAGING_DIR)/usr, creating dangling symlinks.
Diffstat (limited to 'toolchain/uClibc/uclibc.mk')
-rw-r--r--toolchain/uClibc/uclibc.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/toolchain/uClibc/uclibc.mk b/toolchain/uClibc/uclibc.mk
index b595b22d7..c8da46454 100644
--- a/toolchain/uClibc/uclibc.mk
+++ b/toolchain/uClibc/uclibc.mk
@@ -548,9 +548,9 @@ $(TARGET_DIR)/usr/bin/ldd: $(cross_compiler)
CPP=$(TARGET_CROSS)cpp LD=$(TARGET_CROSS)ld \
PREFIX=$(TARGET_DIR) utils install_utils
ifeq ($(BR2_CROSS_TOOLCHAIN_TARGET_UTILS),y)
- mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/target_utils
+ mkdir -p $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils
install -c $(TARGET_DIR)/usr/bin/ldd \
- $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/target_utils/ldd
+ $(STAGING_DIR)/usr/$(REAL_GNU_TARGET_NAME)/target_utils/ldd
endif
touch -c $@